Grub2 Console VGA Modes in Yast

Using Yast to configure the bootloader Grub2.

The list of VGA modes contains only these LOW screen resolutions.

320x200 320x240 320x400 640x400 640x480 800x600
8bit 0x330 0x334 0x331 0x300 0x301 0x303
16bit 0x30e 0x335 0x332 0x33d 0x311 0x314
24bit 0x30f 0x336 0x333 0x33e 0x312 0x315

Taken these VGA modes from OpenSUSE documentation

640x480 800x600 1024x768 1280x1024 1600x1200
8bit 0x301 0x303 0x305 0x307 0x31C
16bit 0x311 0x314 0x317 0x31A 0x31E
24bit 0x312 0x315 0x318 0x31B 0x31F

Are there not any higher resolutions than 1600x1200x24 in VGA Mode? Why am I not getting these higher resolution vga modes in Yast bootloader configuration?

Setting VGA mode to 0x31F gives me a better console resolution: I have to write the Hex only, because writing “1600x1200, 24bits (modus 0x31F)” does not work.
GRUB_CMDLINE_LINUX_DEFAULT=“resume=/dev/disk/by-id/ata-WDC_WD1500HLFS-01G6U0_WD-WXLY08136254-part1 quiet showopts vga=0x31F”

Output from vbeinfo in Grub command line:

VESA BIOS Extension Video Driver
VBE Version 3.0
 x 0x14d 2560x1440x32 (10240) Direct Color, mask: 8/8/8/8, pos: 16/8/0/24

OpenSUSE 13.1
NVidia GeForce 650Ti
Nvidia graphics driver 331.67 (installed via RPM repository)
Monitor resolution: 2560x1440

Don’t think vga is defined above 1600x1200

Looking it up I see that 1600x1200 is actually UXGA which I guess is a VGA based standard

Yast shows higher res on my machine maybe the problem is with the handshake with your video card.

Could you elaborate on this handshake? Is there somehow I can check if this is the problem and possibly correct it?

For some reason the driver is not reporting all the options. So they are not getting listed. Note that the driver at the boot is not the NVIDIA driver which is loaded later. I think it may be using the BIOS video. So maybe the monitor is not hand shaking with the software Why not just try a higher res entry and see if it works. even if the monitor can’t be read at grub it should still boot