Grub2 bootet Windows 7 plötzlich nicht mehr

Hallo,

ich habe hier ein Windows 7 / openSUSE 12.2 Dualboot System. Plötzlich kann Grub2 aber Windows 7 nicht mehr starten, mir ist nicht bewusst, was sich am System geändert haben könnte.

Windows 7 ist auf /dev/sda2

Der Grub2 Eintrag sieht so aus:


menuentry 'Windows 7 (loader) (auf /dev/sda2)' --class windows --class os $menuentry_id_option 'osprober-chain-F8A40E64A40E25AA' {
    insmod part_msdos
    insmod ntfs
    set root='hd0,msdos2'
    if  x$feature_platform_search_hint = xy ]; then
      search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos2 --hint-efi=hd0,msdos2 --hint-baremetal=ahci0,msdos2 --hint='hd0,msdos2'  F8A40E64A40E25AA
    else
      search --no-floppy --fs-uuid --set=root F8A40E64A40E25AA
    fi
    chainloader +1

Ich habe dann mal einen einfachereren Menüeintrag probiert, der geht aber auch nicht:


menuentry "Windows 7 Malte" {
    insmod part_msdos
    insmod ntfs
    set root=´(hd0,2)´
    chainloader +1
}

Wenn ich Windows 7 booten will, lande ich wieder im Grub2 Menü, eine Art Bootschleife, die sich immer wieder wiederholt.

Ich habe dann mal von einer Windows 7 Reparatur CD gebootet und die automatische Reparatur probiert, hat auch nicht geholfen.

Habt ihr eine Idee, warum Grub2 Windows nicht mehr bootet?

Gruß

Eine Idee hab ich nicht, aber hiermit kann man wieder alle Systeme booten:

Super Grub2 Disk - Rescatux & SG2D

Nur den Windows-Bootloader wiederherstellen geht so:

Bootsector & Bootloader wiederherstellen