grub trouble with SATA emulation AHCI RAID

Dear all,
I’ve installed at a Compaq dc5850 (AJ456AV) opensuse 11.1 straight forward without problems. Ine the system Bios 786F6 v03.07 I’ve used the SATA emulation AHCI RAID instead of Legacy IDE or native IDE. The motherbord has an AMD RAID BIOS version 3.0.1540.27. It controls the only one disk as 1+0 JBOD.
Now, when I reboot, grub starts:
"Attemting Boot from Hard Drive
GRUB Loading stage2…
initialize gfx "
And then the system starts to reboot again and again.

There is only one workaroud I do not understand:
If I choose in Boot Menu “Bootdevice: CDROM” it works.
The opensuse 11.1 starts with menu and I choose “Boot from harddisk YES” and the grub from my hard disk starts without any problems the installed opensuse 11.1 system

I have no idea how I can solve the problem. I disabled in the BIOS the RAID controller, but it does not help because then only the CDROM is available. I will not go back to Legacy IDE. Has anyone an idea or a solution hint for that problem ?
Best regards

How about some hard information for the gurus like:

cat /etc/fstab
cat /boot/grub/menu.lst

Then they have something to meditate on :wink:

I could find the problem, it is not because of AHCI or RAID, it’s a graphical problem.

But, I have not yet the solution. The gfxmenu does not come up. I removed for testing the:

gfxmenu (hd0,2)/boot/message

from the menu.lst

Now grub was not crashing but I could not anymore boot. Is there a possibility to remove the graphical SuSE environment from grub options so that I can boot with alphanumerical black screen ?

Modified by YaST2. Last modification on Fri Sep 4 17:41:06 CEST 2009

default 2
timeout 8
gfxmenu (hd0,2)/boot/message
##YaST - activate

###Don’t change this comment - YaST2 identifier: Original name: linux###
root (hd0,2)
kernel /boot/vmlinuz root=/dev/disk/by-id/ata-ST3160318AS_9VY1GLT9-part3 repair=1 resume=/dev/disk/by-id/ata-ST3160318AS_9VY1GL
T9-part2 splash=silent showopts vga=0x345
initrd /boot/initrd

###Don’t change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe – SUSE LINUX
root (hd0,2)
kernel /boot/vmlinuz root=/dev/disk/by-id/ata-ST3160318AS_9VY1GLT9-part3 showopts ide=nodma apm=off noresume edd=off powersaved=of
f nohz=off highres=off processor.max_cstate=1 x11failsafe vga=0x345
initrd /boot/initrd

title Windows XP
rootnoverify (hd0,0)
chainloader +1
--------------------------------------now, fstab
/dev/disk/by-id/ata-ST3160318AS_9VY1GLT9-part2 swap swap defaults 0 0
/dev/disk/by-id/ata-ST3160318AS_9VY1GLT9-part3 / ext3 acl,user_xattr 1 1
proc /proc proc defaults 0 0
sysfs /sys sysfs noauto 0 0
debugfs /sys/kernel/debug debugfs noauto 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0
/dev/disk/by-id/ata-ST3160318AS_9VY1GLT9-part1 /windows/C ntfs-3g users,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8 0 0

I tried to study the GRUB docs (info grub) but I am not sure. You may try to use


instead of

gfxmenu ...

I’ve still have the problem. The proble must be the AHCI option in the BIOS. If I set to Legacy IDE the opensuse 11.1 is booting without problems. If I set the BIOS option to AHCI RAID, then the grub freezes. But, If I start from opensuse CD and go then to “Boot from Harddisk” the same grub starts openSuSE withoutr problems, its amazing, but not understandable for me.

Dear all,
I still have the strange grub problem in SATA AHCI RAID mode on my HP dc5850. The grub of harddisk goes on until:
grub> root
(hd0,2): Filesystem typeis ext2fs, partition type 0x83
grub> setup (hd0)
Checking if “boot/grub/stage1” exists… yes
Checking if “boot/grub/stage2” exists… yes
Running “embed /boot/grub/e2fs_stage1_5 (hd0)” …

from this message on the system freezes.
If I start from DVD opensuse 11.1 and then go to: “Boot from Harddisk” the same grub goes further on like this:

Running “embed /boot/grub/e2fs_stage1_5 (hd0)” … 17 sectors are embedded.
Running “install /boot/grub/stage1 (hd0) (hd0)1+17 p (hd0,2)/boot/grub/stage2 /boot/grub/menu.lst”… succeeded
…and I can boot.
Does anyone know more details about this check:
Running “embed /boot/grub/e2fs_stage1_5 (hd0)” … 17 sectors are embedded. ?