grub-set-default gone missing 11.3


Starting a few days ago, I am unable to leave my kde session using the “leave” facilities.

On a fresh login, I can select the leave button and it pops up the menu as per normal. However, whatever I select (logout, shutdown or reboot) nothing happens. I cannot now select the leave button. I click it but nothing happens.

I checked the log messages and see an error posted by kdm that grub-set-default is not in the path.

I issue a find and, yeps, no grub-set-default.

A week or two ago, I uninstalled CUPS. Went to make tea, came back to find a huge list of stuff being deleted. I had to abort it and spent a long while re-installing loads of stuff, for instance, even Mozzila.

Can’t find where to get grub-set-default so anybody know where to get it?

Cheers and TIA - AK

I asked YaST and it seems that grub-set-default is part of the package trustedgrub. I do not have in installed on my system, but I do not use Gnome and it seems to have to do something with Gnome.

BTW if you borked your system two weeks ago and you still find strange things to happen, you can be sure that your repair was not completely successfull. I would at least check with a backup you made before that uninstall if you have evrything (I hope you have a backup and have a list of installed software in there). Else better reinstall (keeping your */home *of course).

Hi hcvv,

How did you ask Yast? I did a search and it showed nothing. Mind you, I don’t have trusted grub installed so.

I looked at another SuSE 11.3 box this morning and couldn’t find grub-set-default there either. Went through the log and saw many instances of the error message from kdm about grub-set-default.

So… This means that this is not the cause of the problem.

I do take your point vis-a-vis the re-install though and I will have to go back to the box and go over it again. Maybe re-install the whole KDE environment.

Thanks for the response.

Cheers - AK

Type grub-set-default in the Search field and check the box File list below it. After all you are seaaching for the package that installs a particular file aren’t you?

I finally solved this!

zypper verify threw up a message to do with a language option for gstreamer. Installed as suggested by zypper and now all is back to normal.

What has gstreamer to with it? I do not know but maybe something to do with the logout sounds playing.