Grub> screen : what next ?


I did nothing special on my config but updates (zypper ref && zypper up) , nonetheless since a few days i had a black screen listing my devices and F1 to enter setup and F2 to continue.
F2 boots ok untill the desktop of Leap 15.3.

WHen i stroke F1 it entered the bios of Msi and there i chose discrad and exit (i had changed nothing ) Then the pc went to Grub> screen instead of booting as usual
I usually have an image of the mother board brand when i boot, then it enters the graphical menu and then boots untill Leap15.3 automagically, a big Leap ;=) ]

But today i had a black Grub> screen and no clue why i came there.
I tried various commands and exit helped to boot properly.

Why does it boot to Grub> screen ?

What would you recommend to control when you boot to this black Grub> screen ?

Thank you ;=)

Possibly because, the Mainboard’s UEFI/BIOS couldn’t find the disks.

But, before you dive into the instructions of rescuing the system by means of the installation medium – either a bootable DVD or, a bootable USB device – please check the Mainboard’s UEFI/BIOS –

  • Please check that, the UEFI/BIOS has recognised the disk drive(s).
  • Also, please check the Secure Boot status – you may have to temporarily disable Secure Boot to get the system booted and then, repair the Secure Boot security keys …


i read but it did not help ; i tried the command to renew grub but it did not help.

what am i supposed to do from the grub> screen ?

how do you check that the bios does recognize all disks ? just seeing them there ?
(Is it possible for the bios not to see all of them when lsblk does see all of them like in my case )

i checked about secure boot, it is on and never bothered before, do you mean it can suddenly bother the boot ?

today i could not enter the bios as i had an A2 code on a black screen, and this alone.
(DO you happen to know for sure what A2 code means for an Msi Motherb board, disks not seen ok afaik but i’m not entirely sure)

I opened pc, removed battery of the MB, did not help, unplugged cable from dvd player …still with A2.
I then removed the cable from the system HD and came to a big error of grub saying os is missing (ok it was indeed).
Replugged the HD and then boot went ok \o/

I looked it up and found the most logical meaning of A2 for your situation is the BIOS didn’t find any bootable device. After the BIOS reset and reconnections it seems it straightened itself out if it’s behaving normally now. I would buy or find another SATA cable to have to try in case the problem returns. I would also run smartctl to verify the HD is not failing. Another possibility is CMOS corruption from a weak battery. I would check its voltage or just replace it. New ones typically check out at 3.2. If it’s much below 3.0v don’t take a chance putting it back in instead of installing a new one. Yours is probably 6 or more years old, a reasonable life, if shorter than expected. If it’s a typical MSI PC motherboard, it’s almost certainly a common lithium 2032 like my MSI a year older than yours has, simple to change if there aren’t cables or graphics card in the way.

Hello ,)
I tought it was ok, but today when booting it went back to the black screen offering two choices F1 is settup and F2 is to continue.
I used F2, pc rebooted and then entered usual graphical boot process.
I need to check the mother board battery and buy a new one probably.

with gsmartcontrol i can’t see errors in the attributes tab. only one disk failed ‘in the past’ (airflow temp)

Current Euronics CR2032 price here – 10 € for two – 14 € for four.

  • For you – Boulanger – two cells for 8 €.

I wouldn’t bother to check the dead cell – simply drop into your local electrical supplier (Les magasins Boulanger en Haute-Savoie → Annemasse, Publier, Scionzier, Seynod) …

Actually i have some Tronic CR2032 3V 230mAh cells available but a brand new one i tested is given low already… strange for they’re given good untill 02/2023 and were made in 11/2019 (says the package).
I’ll try to see if the others are low too.

Quality control on coin cell batteries not carrying major brand names is all over the place. I last got a card of 9 for $5.00 US or less from a friend who got it at a flea market and gave to me. The ones I have now have no brand name, just say 2032 Lithium Cell 3V, with no date on the package.


An extended self test of the system HD from gsmartcontrol gave an Ok result :slight_smile:

I still have the same strange behavior as in message #5 , it only boots after i strike F2 (continue).

I tested the batteries i had in stock, they are too low already but a tiny bit better than the one from the MB so i put one on the motherboard to replace the old one. ( the one on the motherboard (MB) is a Kts battery that is tested at zero …)

I’ll try to find some good 10 years lifetime CR2032, with the max mAh amount if possible, and then see if it is better.

Just passing by and had a similar situation that just showed up in my Leap 15.3 install and it remained even after upgrading to 15.4 . . . .

I got the grub> screen when trying to boot Leap, previously everything had been running OK . . . . I like to start with the obvious and offer that the “grub>” screen possibly indicates that there is a “grub problem” . . . .

Step one is to procure the appropriate edition of Supergrub2 and burn it to CD/DVD or install to flash drive . . . boot the machine to SG2 disk and use it to boot the installed system . . . . That would be your proof that there is a grub issue. If you can boot the system that way the solution that worked for me was to launch Terminal, log in as root and run


. . . . Seconds later you should be back in the biz.

In my case I ran Yast bootloader, I ran the “grub2-mkconfig xxxxxxxx” command, I booted the install disk and ran “rescue” . . . AND even after I upgraded via iso and saw “installing grub2” . . . in the installation listings . . . still the system had no grub . . . . I had to manually install it as shown above . . . .

Hello, i was waiting for a battery i ordered. I tested my old battery from the MB ; it was at zero. A new one i had was low but better than the old one. I tried with it, 1st boot gives the screen i described above but after the 1st boot it boots as usual, which makes me think it is a battery problem. I’ll change for the new cell i just received and i guess it should be ok then.

Alrighty, well, my question to that is, what does battery have to do with “finding grub”??? Not enough battery to power the nanobots to find grub and boot the system, but enough to power the TTY and show the “grub error”??? It may be that there is a battery problem AND a grub issue?? But, very cool if the problem is in fact resolved . . . .