Grub Recovery


Thanks for any help and advice (it is VERY much appreciated)

I had dual boot (Windows Vista and Opensuse 11.1). Service Pack 2 came along and wrecked my machine and required repair installation - and wiped Grub. Also, i had to mark Windows partition of hard drive as “active” as this was the only way to get SP2 installed.

I have lost Grub and my linux partition reports “no volume associated with this partition”

Windows Diskpart sees my partitions like this:

**Partition ### Type Size Offset

Partition 1 Primary 504 GB 1024 KB
Partition 0 Extended 428 GB 504 GB
Partition 2 Logical 2055 MB 504 GB
Partition 3 Logical 20 GB 506 GB
Partition 4 Logical 406 GB 526 GB**

Grub, sees my partitions like this:

**Partition num File System Type

Partition 0 NTFS 0x7
Partition 4 Unknown 0x82
Partition 5 ext2fs 0x83
Partition 6 ext2fs 0x83 **


find /boot/grub/stage1

resulted in “Error 17: File not found”. I tried booting from the live CD, but was unable to boot from the hard disk. When i booted from the live CD all the way, there were no entries found for:


So i’m pretty stuck.

  • No Grub.
  • No volume associated with Linux partition.
  • No MBR entries or config files.

Help - how do i recover opensuse? Windows Vista killed my machine.

Any help and/or advice is VERY much appreciated!

I tried:


… but not got it to work yet.

Best regards, samwootton

How do i delete this thread?