GRUB prompt after update

Our image was a bit out of date so we decided to cheat and just do a zypper dup
We don’t normally do that we just make a new image but we tested it on a load
of machines and everything seemed fine. Everything worked fine for about a week.
No issues, no problems, everyone was happy. Then Monday six machines failed to
start hanging at GRUB. Today there were three more. Using the install DVD and
doing a rescue fixes the problem. The question is why did they all work perfectly
and then fail. All the machines that fail have one type of motherboard ( an Intel
DH66 ) none of the other machines with other Intel motherboards have a problem.
All the machines that have the problem are identical. You can take twenty machines
install our image then zypper dup them all. Nineteen will work perfectly one will fail.
The HD’s check out as Ok. Any ideas anyone - apart from don’t zypper dup them :wink:

Ta

M

On 2013-09-10 11:36, interele wrote:
> Any ideas anyone - apart from don’t zypper dup
> them :wink:

It is not clear what you did. What version of openSUSE was before and
what after, for example. What grub version. What did you do before
Monday morning (“nothing” is not acceptable :-P). What message did they
print. Etc.


Cheers / Saludos,

Carlos E. R.
(from 12.3 x86_64 “Dartmouth” at Telcontar)

12.3 before and after , The image was made around mid August and we zypper
dup’d them on 2nd September. The only unstable repo we use is LibreOffice so we
can get 4.1.1 the rest are the usual packman and so on, nothing that’s
not in the community repos listed to start with.

What did we do before Monday … er nothing :wink:

the 3rd to the 6th September all the machines were used and worked fine.
Each probably had about 10 users during the day. They are turned off each night
and restarted in the morning. We came in Monday morning turned the
machines on and the six machines got as far as GRUB in white on a black screen.
All the rest started fine. We quickly reimaged those machines so they could be
used and they worked fine. Then today three more ( different ) machines did the same
so we reimaged them and they started fine. So I zypper dup’d these three. Two
restarted Ok and one stopped at the GRUB again. Using the original disk I did a
repair ( as per caf4926’s guide - which is probally what I should have done to the
failed machines in the first place not reimage them ) and that’s now fine. Only
Intel DH61WW based machines seem to have the problem, we have about 90 of
those. The remaining 350ish are DH31’s and DH41’s and none of these have
had any problem. The image was made on the DH61WW.

What I don’t understand is why they worked fine for 4 days, 4 restarts and 40+ logins
then died. If I’d zypper dup’d them and after none started I could understand that or
if all the DH61WW died or all the DH31’s there would be some logic.

Sorry to have written half a book here ! If there is something I’ve forgotten let me know

Thanks

M

What exactly is on this black and white screen? Showing picture would be helpful.

Any chance you are auto updating?