GRUB PASSWORD ERROR - opensuse11.1


I have an upgraded installation of opensuse11.1 from opensuse11.0 the issue am having is no matter how many times i reset the grub password/ reinstall grub the password i set for grub fails apart from that everything is fine. its a dell laptop i use the lock feature to lock other OS in grub as it has multiple OS installed. since the password fails i couldnt use the lock feature in grub.

Here are my settings I have tried every option i have come across the internet, Is it just me who is having this problem or is the grub with opensuse 11.1 has this issue or what ?

I would really appreciate any help. Is there a way to debug grub as there is a debug flag on menu.lst ?

-0-(root@linuxbox) ~]#cat /etc/grub.conf
#setup --stage2=/boot/grub/stage2 (hd0) (hd0,5)
setup --stage2=/boot/grub/stage2 --force-lba (hd0,5) (hd0,5)

-0-(root@linuxbox) ~]#df -h
Filesystem Size Used Avail Use% Mounted on
/dev/sda9 15G 9.9G 4.0G 72% /
udev 994M 232K 993M 1% /dev
/dev/sda6 99M 19M 75M 21% /boot
/dev/sda8 20G 19G 574M 98% /home
/dev/sda3 41G 32G 8.9G 78% /windows/C
/dev/sda5 61G 51G 9.3G 85% /windows/D

-0-(root@linuxbox) ~]#fdisk -l

Disk /dev/sda: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x08000000

Device Boot Start End Blocks Id System
/dev/sda1 1 14 112423+ de Dell Utility
/dev/sda2 15 1320 10490260 7 HPFS/NTFS
/dev/sda3 1321 6542 41945715 7 HPFS/NTFS
/dev/sda4 * 6543 19196 101643255 5 Extended
/dev/sda5 6543 14376 62926573+ 7 HPFS/NTFS
/dev/sda6 14377 14389 104391 83 Linux
/dev/sda7 14390 14651 2104483+ 82 Linux swap / Solaris
/dev/sda8 14652 17262 20972826 83 Linux
/dev/sda9 17263 19196 15534823+ 83 Linux

-0-(root@linuxbox) ~]#cat /boot/grub/menu.lst

Modified by YaST2. Last modification on Tue Mar 3 23:13:52 GMT 2009

gfxmenu (hd0,5)/message
default 0
timeout 8
##YaST - activate
##YaST - generic_mbr
password --md5 $1$ejXkPdIP$oofZF4Yop0/2dJ18itK3Z/

###Don’t change this comment - YaST2 identifier: Original name: linux###
title openSUSE 11.1 -
root (hd0,5)
kernel /boot/vmlinuz- root=/dev/disk/by-id/ata-TOSHIBA_MK1637GSX_X7OCTF66T-part9 resume=/dev/disk/by-id/ata-TOSHIBA_MK1637GSX_X7OCTF66T-part7 splash=silent showopts vga=0x314
initrd /boot/initrd-

###Don’t change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe – openSUSE 11.1 -
root (hd0,5)
kernel /boot/vmlinuz- root=/dev/disk/by-id/ata-TOSHIBA_MK1637GSX_X7OCTF66T-part9 showopts ide=nodma apm=off noresume nosmp maxcpus=0 edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 x11failsafe vga=0x314
initrd /boot/initrd-

###Don’t change this comment - YaST2 identifier: Original name: windows 2###
title Windows Vista Business
rootnoverify (hd0,2)
chainloader +1

-0-(root@linuxbox) /boot/grub]#cat
(hd1) /dev/disk/by-id/usb-WD_3200BEV_External_575848343038333431343238-0:0
(hd0) /dev/disk/by-id/ata-TOSHIBA_MK1637GSX_X7OCTF66T

I have never use a password but looking at the grub manual “lock” should be right after “title”, in your case:
title Failsafe – openSUSE 11.1 -
root ect:

It only matters if you dont want anyone to boot any listed OS without a password. you have to place the lock right after the password --md5 line. The current setup works as expected i cant boot into the locked titles. The only problem i have is password doesnt work. Even i have tried removing all the lock entries and just left the password entry alone, still the password fails.