GRUB/openSUSE absoloutely will not go away

I installed openSUSE yesterday in my ongoing sampling of various Linux distros, but have decided it’s not for me. However, it simply refuses to take no for an answer.

My standard method of getting rid of other unwanted installations (Ubuntu, Debian, Linux Mint) was to use a program called Mbrfix.exe to remove GRUB and then simply remove the partitions. Worked every time with those, had no effect on SUSE’s GRUB.

So I decided to try my Windows XP CD with the Fixmbr command. Reboot… GRUB’s still there. Then I came here and found out about the MBR restoration facility in YaST’s Boot Loader menu. Tried that, up popped confirmation that my boot record had been restored to its pre-SUSE state, reboot and… oh god, it’s GRUB.

So I’m really kinda at the end of my tether here. Does anybody have an idea as to what’s gone wrong? Like I said, I’ve installed several other distros and had no problem removing them after my trial. But nothing I’ve done has had any effect whatsoever, and I’m not sure what to do next. I really don’t want GRUB and openSUSE just sitting there on my system forever.


if you are removing suse, you must be installing something in place? Or do you already have something? Just install your next distro, it sounds like you are on a bit of a run.

If you only installed suse yesterday - And you already decided it’s not for you?

Presume you have xp installed from what you say. The fixmbr in xp should work, I suggest you double check. As you don’t explain your drives and partition set up, I really can’t comment further.

I hadn’t heard they had buildt in a ‘hold on for life’ function in openSUSE’s GRUB :slight_smile:

Fixmbr should restore the Windows boot and is the correct action to take.

Have you also checked to see if the correct partition is still marked active boot? As a side note, when restoring MDB through YaST you are probably restoring the working state with Grub in place :slight_smile:
Fixmbr should restore a Windows boot, or you can try a boot manager like Bootit which can restore a ‘standard’ MBR (keeping partition information intact of course). Retry the fixmbr after that.

Good luck,

The reason is this: Fixmbr only works if the windows bootloader partition is an active partition. Installing Suse deactivates the old active partition (usually partition 1) and instead makes active the Suse partition. Until you restore “active” to the first partition, fixmbr won’t work.

There’s couple ways you can move ahead: is there a windows installation on the drive? Is there a Suse installation on the drive? What’s there ATM?

I have had this problem too. My XP system has an IDE drive and a pair of SATA drives. The key to making FIXMBR work for me was to remove the power supply from the disks that don’t carry the MBR that needs to be updated. Using the WinXP CD to launch the recovery console, FIXMBR gave a message to the effect “you have a non-standard MBR - do you really want to change it?” If you don’t see this message, then FIXMBR is looking at the wrong drive. Setting the boot drive to “SCSI”, which is what my BIOS uses for SATA was not enough on its own even though the Recovery Console found the right system to update. Only unplugging all the other drives worked.

On my system, I find that I cannot boot into the recovery console without slipstreaming the SATA driver into the CD. For a relatively easy intro to this seriously WindowsGeek subject, try searching on “nlite”.