GRUB on Compaq Armada M700

I just installed OpenSUSE 10.3 on my Compaq Armada M700 and the only way to start it is to boot from DVD, start the “System Repair”, and then when it fails for some reason to choose the “boot installed system” from the alternate menu that appears after failure.

When I try to boot normally, I get a message that says “Error starting operating system”. Just before that, Intel Boot Agent 2.6 is starting and I suspect it is the problem. Intel Boot Agent is usually installed on ROMs located on Intel ethernet cards, but when I tried to remove it with IBAUtil tool provided by Intel, it reported that Intel Boot Agent is not installed on my network card. I guess it is installed together with BIOS or on a separate ROM on motherboard on my laptop, so it is not configurable by this utility.

Does anyone have any idea how I could disable this pesky piece of software or force GRUB or SUSE itself to somehow bypass it?

I seem to have resolved the problem. Sorry for posting before I tried everything. I found an option in yast to install GRUB into MBR and now I can boot my SUSE normally. I don’t know if Intel Boot Agent survived this and I don’t care as long as BIOS is undamaged.

Installing Grub into the MBR only affects the MBR. Bios is fine.

I have a similar problem. I have tried installing openSUSE and Kubuntu on a Compaq Armada M700, only to get an error 18 message. I can’t seem to get at the BIOS (all I get from F10 is a Setup menu), and that seems to be part of the problem. The files install, but GRUB won’t load. Any suggestions?

Welcome to the Forums – quite a different problem. I suggest you start a new thread to get attention from the other members.