Grub not using saved boot option

Hello Everyone,

After giving it my best shot, I had to give up and finally decide that I need “acpi=off” added to the kernel line in grub. I have done so, saved it:

kernel /boot/vmlinuz-2.6.31.12-0.2-default root=/dev/disk/by-id/ata-ST950212A_5LE02797-part1

pci=noacpi

I have tried “acpi=off” “pci=noacpi”. But on boot the system totally ignores this and loads the acpi support from the kernal, which shut down the USB ports.

Where is this option used in Suse so that the kernel will recognize on each boot?

Thanks in advance.

Bob

You put the option on a new line, from what it looks like. The option should be somewhere in the line above, preferably after “showopts”. Do not use quotes, and use “acpi=off”, without the quotes, just like the vga=0xXXX statement at the end. But not on a new line.

Thank you for your reply. I realize that what I quoted looked like a new line, but where you suggested is where I have it.

kernel /boot/vmlinuz-2.6.31.12-0.2-default root=/dev/disk/by-id/ata-ST950212A_5LE02797-part1

resume=/dev/disk/by-id/ata-ST950212A_5LE02797-part3 splash=silent quiet showopts acpi=off

The above is the saved menu.lst file. It is still just ignoring that and loading the acpi rules. If I use this at the boot screen, it works. But it is not reading the menu.lst (though obviously it is because it is booting.)

Bob

So, you say, that if you add “acpi=off” manually at the boot options line, it works, but it does not when reading the line from /boot/grub/menu.lst ?
To avoid parsing problems, please use code blocks ““code”]” and “”/code"]", with quotes left out. That will show the line from a file as it is, on a single line, like the one from mine:


    kernel /boot/vmlinuz-2.6.34-9-default root=/dev/disk/by-id/ata-Kingston_SSDNow_64GB_YCBGK0S925SY925B4324-part1 resume=/dev/disk/by-id/ata-Kingston_SSDNow_64GB_YCBGK0S925SY925B4324-part3 splash=silent quiet  showopts acpi=off vga=0x361

Admit, I put the acpi=off in there manually, to show you what it should look like. The bootloader is reading and processing the menu.lst, otherwise you would not have any boot menu at all. My guess is that the option is on the wrong line. Could you post the entire file and put it in code blocks ?

# Modified by YaST2. Last modification on Thu Jun 17 22:20:20 BST 2010
# THIS FILE WILL BE PARTIALLY OVERWRITTEN by perl-Bootloader
# Configure custom boot parameters for updated kernels in /etc/sysconfig/bootloader

default 0
timeout 8
gfxmenu (hd0,0)/boot/message
##YaST - activate

###Don't change this comment - YaST2 identifier: Original name: linux###
title openSUSE 11.2 - 2.6.31.12-0.2
    root (hd0,0)
    kernel /boot/vmlinuz-2.6.31.12-0.2-default root=/dev/disk/by-id/ata-ST950212A_5LE02797-part1
resume=/dev/disk/by-id/ata-ST950212A_5LE02797-part3 splash=silent quiet showopts acpi=off
    initrd /boot/initrd-2.6.31.12-0.2-default

###Don't change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe -- openSUSE 11.2 - 2.6.31.12-0.2
    root (hd0,0)
    kernel /boot/vmlinuz-2.6.31.12-0.2-default root=/dev/disk/by-id/ata-ST950212A_5LE02797-part1 showopts apm=$
    initrd /boot/initrd-2.6.31.12-0.2-default

Sorry about the quotes in previous post. I know better.

Thanks for looking at this.

Bob

UPDATE: It appears that you are indeed correct. Somehow, the line had been separated into a new line and I could not determine that from this laptop screen. All sorted now.
Thank you for your help.

By the way, what is the vga=??? to get the proper splash screen. I am getting only a text boot. And, I am using the vesa driver (nothing else available for this VIA/S3 chipset) Would the openchrome driver help and if so, where is it?

I apologize for these silly questions, but I am not familiar with Suse and I am doing this for a friend.

Bob

There is a new line in the file. See:

# Modified by YaST2. Last modification on Thu Jun 17 22:20:20 BST 2010
# THIS FILE WILL BE PARTIALLY OVERWRITTEN by perl-Bootloader
# Configure custom boot parameters for updated kernels in /etc/sysconfig/bootloader

default 0
timeout 8
gfxmenu (hd0,0)/boot/message
##YaST - activate

###Don't change this comment - YaST2 identifier: Original name: linux###
title openSUSE 11.2 - 2.6.31.12-0.2
    root (hd0,0)
    kernel /boot/vmlinuz-2.6.31.12-0.2-default root=/dev/disk/by-id/ata-ST950212A_5LE02797-part1
resume=/dev/disk/by-id/ata-ST950212A_5LE02797-part3 splash=silent quiet showopts acpi=off
    initrd /boot/initrd-2.6.31.12-0.2-default

###Don't change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe -- openSUSE 11.2 - 2.6.31.12-0.2
    root (hd0,0)
    kernel /boot/vmlinuz-2.6.31.12-0.2-default root=/dev/disk/by-id/ata-ST950212A_5LE02797-part1 showopts apm=$
    initrd /boot/initrd-2.6.31.12-0.2-default

should be:

# Modified by YaST2. Last modification on Thu Jun 17 22:20:20 BST 2010
# THIS FILE WILL BE PARTIALLY OVERWRITTEN by perl-Bootloader
# Configure custom boot parameters for updated kernels in /etc/sysconfig/bootloader

default 0
timeout 8
gfxmenu (hd0,0)/boot/message
##YaST - activate

###Don't change this comment - YaST2 identifier: Original name: linux###
title openSUSE 11.2 - 2.6.31.12-0.2
    root (hd0,0)
    kernel /boot/vmlinuz-2.6.31.12-0.2-default root=/dev/disk/by-id/ata-ST950212A_5LE02797-part1 resume=/dev/disk/by-id/ata-ST950212A_5LE02797-part3 splash=silent quiet showopts acpi=off
    initrd /boot/initrd-2.6.31.12-0.2-default

###Don't change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe -- openSUSE 11.2 - 2.6.31.12-0.2
    root (hd0,0)
    kernel /boot/vmlinuz-2.6.31.12-0.2-default root=/dev/disk/by-id/ata-ST950212A_5LE02797-part1 showopts apm=$
    initrd /boot/initrd-2.6.31.12-0.2-default

So, remove the newline before “resume=”, that’s what’s causing all. I bet you’ll have a splash screen afterwards too.

In fact, it’s quite funny now that it’s clear. There’s a new-line that does not cause any errors, the things on the line simply are not recognized as boot options.

About the vga= question, try vga=0x317 (1024x768), or vga=normal