grub not loading opensuse

I’m trying to install Opensuse 11.3 on an external usb hdd. i’ve disconnected my internal disks from the computer and attempting to install via Opensuse Live disc.

After the installation i get a message sayin, installation successful, you must reboot without Live CD. On which the system boots into grub command prompt and doesn’t start. I read around in the forum where it says to point the grub to root and repair broken link, now i get an grub error message 21

I have tried installing many times, but it doesnt start…

what am i doing wrong?

Boot from the Live CD, open a terminal window and show us the output of:


fdisk -l

Oops, almost forgot, a warm welcome to the forums

You said “…boots into grub command prompt”. If that truly is a grub command prompt, you might be able to repair the linkage from the grub command line. So exactly what does the “grub command prompt” that you see look like?

this is the result. i don’t get a grub command prompt any more. it says Grub loading and then error 21

Disk /dev/sda: 250.1 GB, 250059350016 bytes
255 heads, 63 sectors/track, 30401 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x473649f7

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1               1         262     2103296   82  Linux swap / Solaris
Partition 1 does not end on cylinder boundary.
/dev/sda2   *         262        2873    20972544   83  Linux
/dev/sda3            2873       30402   221121536   83  Linux

can grub be re-configured from live cd itself?

Yes
This guide will help:
Re-Install Grub Quickly with Parted Magic

Parted M is a live cd, but a suse cd will do, you just have to type su in the terminal and hit enter a couple of times
Then follow the guide

tried following the procedure. at boot i got error 21…

i formatted and installed the system again… now upon boot i first get a message No boot devices found-Press any key to continue. after u hit a key it takes u to GRUB v.0.97 and a prompt like “Grub>” also it says root: (hd0,1)

why does not it take me to the GUI directly… is there a problem with boot device? i’m using USB HDD. and have enabled USB boot and boot options in the BIOS to let it boot from USB.

Hello!

I have a similar issue. Successfully installed 11.3 x64 on a USB HDD. Grub is in USB HDDs MBR. Upon reboot USB HDD boots and grub shows up with choices (opensuse + failsafe). I choose to boot opensuse, then I get a message:

Trying manual resume from /dev/disk/by-id/usb-HDS…HDDserialnumbersandstuff…-0:0-part1
/dev/disk/by-id/usb-HDS…HDDserialnumbersandstuff…-0:0-part1 not found (ignoring)
Waiting for device /dev/disk/by-id/usb-HDS…HDDserialnumbersandstuff…-0:0-part1 to appear: … Could not find /dev/disk/by-id/usb-HDS…HDDserialnumbersandstuff…-0:0-part1.
Want me to fall back to /dev/disk/by-id/usb-HDS…HDDserialnumbersandstuff…-0:0-part1 (Y/n) <-*no matter what I choose
y
Waiting for device /dev/disk/by-id/usb-HDS…HDDserialnumbersandstuff…-0:0-part1 to appear: … not found – exiting to /bin/sh
sh: cannot set terminal process group (-1): Inappropriate ioctl for device
sh: no job control in this shell
$

Opensuse 11.2 x64 works OK (same setup-no changes).
(Fedora 13 x64 works as well. I connect/disconnect the drive and it always boots. Fedora 12 x64 installer cant even see the USB HDD).

Any hint on whats going on? (Do I need to pass something to the kernel on boot or 11.3 doesnt load usb-storage kernel module?)
Please help…

Nobody? It cant be that bad… O_o

Try removing resume=/dev… from your openSUSE 11.3 boot entry and replace root=/dev/disk… with the correct device. (you can use /dev/sdxx as well once you find out on which partition your OpenSUSE 11.3 kernel is located.)

OK, so I installed 11.3 again (live iso) with root in extended partition. It does the same. Everything is smooth until the first boot. Then I tried the proposed “resume=…” and “root=…”. Bootloader takes in the new options but result is the same. Instead of “waiting for device /dev/disk/by-id/usb-whatever…” its “waiting for device /dev/sddx/…”
At 11.3 bootloader setup I checked to boot from “Extended”, “/” and also from “MBR” of that USB Drive. (could this do no good?)

Then I installed 11.2 after 11.3 to a different partition. Installation went smooth and also booting is OK. It detected the 11.3 installation and chainloads it, but thats it. I checked 11.3 grub/menu.lst from LiveCD, but nothing seems wrong. 11.2 is booting the same way as 11.3 (same “Trying manual resume from /dev/disk/by-id/usb-HDS…HDDserialnumbersandstuff…-0:0-part1” messages without errors). I dont understand :frowning:

Maybe Im missing something simple in my desperation. Im not that well oriented in the workings of linux yet. And I would really love to use 11.3.

I found something old but fitting the situation quite well: OpenSuse 10.3 Installation Help
“openSuSE 10.3 now uses libata also for IDE-harddisks which treats all drives like SCSI devices.”
“Use this boot parameter…to disable libata: hwprobe=-modules.pata”
I was wondering if this could still be relevant. Its an old IDE HDD (in ext.box) after all. The internal HDDs are all SATA.

On 2010-08-25 16:29, shreeyashattal wrote:
>
> this is the result. i don’t get a grub command prompt any more. it says
> Grub loading and then error 21

21 : Selected disk does not exist
This error is returned if the device part of a device- or full
file name refers to a disk or BIOS device that is not present or
not recognized by the BIOS in the system.


Cheers / Saludos,

Carlos E. R.
(from 11.2 x86_64 “Emerald” GM (Elessar))

On 2010-09-01 01:36, bluelizard wrote:
>
> I found something old but fitting the situation quite well: ‘OpenSuse
> 10.3 Installation Help’ (http://tinyurl.com/3xccpxw)
> “openSuSE 10.3 now uses libata also for IDE-harddisks which treats all
> drives like SCSI devices.”
> “Use this boot parameter…to disable libata: hwprobe=-modules.pata”
> I was wondering if this could still be relevant. Its an old IDE HDD (in
> ext.box) after all. The internal HDDs are all SATA.

No, no.

First, because that old interface will disappear.

Then, because that external disk is connected via usb, linux doesn’t even see if it is parallel or
serial ata. As far as linux is concerned, it is usb.

Your error is still:

Trying manual resume from
/dev/disk/by-id/usb-HDS…HDDserialnumbersandstuff…-0:0-part1
/dev/disk/by-id/usb-HDS…HDDserialnumbersandstuff…-0:0-part1 not
found (ignoring)

correct?

Try removing the “resume=…” entry from the kernel line.


Cheers / Saludos,

Carlos E. R.
(from 11.2 x86_64 “Emerald” GM (Elessar))

Yes, error still remains the same.

Unfortunately removing “resume=…” didnt help. Same error. (I edited …/grub/menu.lst from a livecd to be absolutely sure)

I connected the HDD this morning as an internal drive (can be just temporary-different story), installed oS11.3 on it and it was running/booting fine (even chainloading other OSs). Then I put it back into the ext.box and the error appears again (bootloader is OK,also still chainloading other OSs).
I dont have any clue what to look for or where :frowning:

On 2010-09-02 02:36, bluelizard wrote:
>
> Yes, error still remains the same.
>
> Unfortunately removing “resume=…” didnt help. Same error. (I edited
> …/grub/menu.lst from a livecd to be absolutely sure)

You removed the “resume=…” entry, and it still complained that it was attempting to resume from
somewhere, and not finding it? Wow. :open_mouth:

>
> I connected the HDD this morning as an internal drive (can be just
> temporary-different story), installed oS11.3 on it and it was
> running/booting fine (even chainloading other OSs). Then I put it back
> into the ext.box and the error appears again (bootloader is OK,also
> still chainloading other OSs).
> I dont have any clue what to look for or where :frowning:

Me neither, sorry.


Cheers / Saludos,

Carlos E. R.
(from 11.2 x86_64 “Emerald” GM (Elessar))

OK, the IDs don´t give me rest. Obviously theres always something wrong with them. They are always too long to remember so I did not paid too much attention (mainly to the ending part which seems to change).
That of course doesn´t explain why the system is not booting when I assign /dev/sdd# to it. (I checked fdisk -l at the rescue prompt to be sure).
I tried doing something like this: Cloned machine does not boot up properly but even if fstab is changed the error just to be /dev/sdd2 and 5 (same like when I remove resume=… and use root=sdd5…)
What bugs me anyway: I installed the USB LiveCD stick onto USB HDD. Could it be setup so that the USB HDD inherits the IDs from the USB stick for the HDD installation? Ive done it so many times I don´t even remember all the possibilities now.

Alrigt. Now Im going to try to compare real IDs with those in menu.lst … Then I´ll try to boot the system with partition labels (as I read somewhere). If Im still alive after all that I´ll report my findings.

Alright its gone FUBAR (as usual).
I´ve tried everything I suspected might be wrong, but nothing. I´ve tried to boot by device path, by changing the device id, by label, but everytime it just stuck with the same old message. I´ve been editing the menu.lst, then also fstab to match menu.lst, then tried different boot options. Nothing…

When I installed oS11.3 onto that drive as a USB HDD it had different device id than when I connected it internally (obviously). So I changed the numbers in fstab and menu.lst (to the “usb” ones). Bootloader got further this time, loaded some more stuff than usually and then the same message came on wanting the new (connected as “internal”) numbers.
All this was performed on oS11.3 installed on the HDD connected internally.

Last thing on my mind: Install oS11.3 yet again, and choose other booting method (by label or whatever) during the installation.

I´m still open for any suggestions. If I get lucky I´ll post of course…

Some links for the interested:
How to clone HD when using UUID in fstab?
Cloning a vdi file with openSUSE insalled (View topic) • virtualbox.org
Cloned machine does not boot up properly
New default in SLES/SLED 10 SP1: mount “by Device ID”
device not found
waiting for device /dev/disk/by-id/

Super Grub Disk can often be helpful.

ABSOLUTELY UNBELIEVABLE !!!
OK, now Im really pissed. WTF is wrong with this thing? I just reinstalled for like 16287426841st time and after boot same error: waiting for a label and then wanting to fall back to /by-id ****…

Its really annoying beyond belief! Its been like two weeks or so! Im hearing my self growing old in that time! The developer will have that app ready for windows before I even succeed installing something usefull. Suse crapped out on me like this, Fedora is after considerable amount of troubleshooting installing/booting OK, just to hard freeze right after that (YYEEEHHAAA!), and Im not even going to think about what would had to be done to that ancient centos 5.5 installation to make it a workstation… really,really,really,really,really,REALY frustrated

Alright, I try SuperGRUBdisk but from the looks of this the GRUB itself actually works (v1.5 i believe). It loads that **** OS, but after THAT Its all the same bullsh*t. GRUB installed by opensuse11.3 loads everything on the drive, and even something not on that drive. But oS11.3 is single thing not working on my PC and in wide vicinity.

My patience went down the sewer before the last post. But I will leave it as is for some time, in case someone magically discovers a (very simple) solution to this. Im getting sure that definitely its something wrong with 11.3 version and it should be discovered so it would not make it into 11.4 final. (i.e. As there was in F13 DVD installer-plenty room on DVD, missing 16kb kernel module)

meh…
<:(