GRUB not loading "No Linux root partition found"

I installed a new hd (250gb) and migrated my existing dual boot system (XP & 10.3) from a 150gb disk to it. I used Acronis from Windows. I kept the partition sizes the same, as I wanted to change the sizes later on.
Now GRUB won’t load and I can’t boot to anything. I tried this tutorial GRUB Boot Multiboot openSUSE Windows (2000, XP, Vista) using the Grub bootloader.
and the Suse installation tells me “no Linux root partition found”.
Needless to say, that I tried Super Grub Disk and nothing worked. Not even booting to Windows.
What do I do now? Is there a better way of migrating the system than Acronis? I still have my old hd, so I could try migrating a different way…

Boot from the XP cd with the recovery console and give the following commands:

This will give you windows

Now for SuSE use what I do, a third party bootloader called gag
GAG, the Graphical Boot Manager

Just remember you will have to install GRUB into your root partition first. All instructions are given in the gag archive.

Acronis should get the job done… Nothing wrong with that.

Do your partitions still have the same layout? It could also be that there is no active boot partition set.

I’m not familiar with the super grub disk, but have you also tried using the openSUSE install DVD in recover/repair mode?

An older post, but can give some info of which files are good to keep an eye on when imaging to another disk or moving partitions around : Good Things To Know When Imaging Linux To Different Hardware - openSUSE Forums
As you did a full disk copy the partition layout should have been maintained, but always good to check :wink:
p.s. the mkinitrd is not needed here as you are still on the same hardware…

First you should clone only the windows partition using acronis and see if it is bootable. Then you can clone the linux partition and reinstall GRUB.

There’s one more important thing…always shutdown the system after each process. Usually people reboot the system, and thats the mistake they make.

Hi CurnyTail,

Curious to what would be wrong with rebooting in this process? The MBR table is re-read either way?

In my experience dual-booting winxp/linux, linux is able to successfully write GRUB to the MBR only if the system is shutdown.

If you reboot, there is likely to be a failure writing GRUB. It doesn’t happen in all systems though.

I also noticed the same with the winxp install cd. Its able to ‘fixmbr’ only if the system is shutdown-and-switched-on, and not rebooted.

Are both SATA or PATA?
Or is one SATA and the other PATA?