grub menu key and zero timeout

so after removing windows id like to pass over the grub screen …but be able to access for possible rollbacks. I have tried the shift key and nothing happens (despite that leap 42.3 docs/ref claim it does). After recent mailing list post a user suggested the escape key, but for my laptop this gives the bios menu. Thanks for suggestions.

The shift key is used to display the menu if it is hidden. Your question sounds like you are trying to hide the menu. You can use the YaST Boot Loader gui to change the settings.

for anyone else that thinks the OP is a total imbecile and would hold the shift key to hide the menu:

menu already disabled with zero timeout.
the shift key DOES NOT WORK in displaying grub menu (either by repeated press or constant press)

I apologize if I have insulted you, no intention to just the way I read the question.

When I have the “Hide” option set, or the time set to 0, when booting I get a quick display of pressing the letter t to show the menu. I have just performed several reboots and pressing the letter t works for me.

Hope this helps. Sorry again if it doesn’t.

It could also be that you did not explain your case clear enough so that people are coming to incorrect conclusions or assumptions. Suggesting that someone, who is pending his spare time in trying to help you, is thinking you are total imbecile is the best way to assure that you will not get any answer at all in the future.

thanks for your investigations but neither shift key nor the ‘t’ key appear do anything (and escape opens bios)

Wait a bit longer before pressing the t key. You want to get past the bios, and for me, even with time set to 0, there is a brief screen displayed prompting you to press the t key, but by the time you have read it, it is too late. Press the t the moment it appears.

Yes, indeed. I had considered ignoring this question for that very reason, but:

To OP:

Before you can use the “Hold Shift Key” trick, you must first set it up.

Go here:

Check the following message, as well. You will need to remake and reinstall Grub.

Thanks, that solved it.

Yes, I have seen the same thing mentioned for Grub various places on the internet, so is that a mistake in the documentation or otherwise? I don’t know, but my script solves it. I use it on a lot of my machines.

Keep in mind, much of the online documentation ends up getting outdated because we simply do not have enough volunteers with enough knowledge about the subjects and the time to spend updating the knowledge base.

Most of those with the knowledge are already snowed under developing, fixing, and maintaining.

Anyone is welcome to pitch in, and if you wish to help, you could look into finding the correct answers for that document and fixing it. Just follow the links about contributing to openSUSE.