GRUB loader aparently not installed

Well, I just installed SUSE 11.0… but the grub loader isnt working, I have XP, and another distro on my harddrive. But now I dont get any boot options, the computer just loads XP as if it was the only thing on there.

So what do I do here? to get a working GRUB?

Are you able to see the green GRUB boot menu on starting?

It would help if you could tell us your detailed system configuration, HDD partitioning, disk sizes etc.

FYI: I personally use grub4dos to dual-boot into XP/Opensuse.
See here:

[SOLVED] Booting into an installed opensuse 11 system with grub4dos - Boot Land](

No GRUB menu, just drops into winXP load screen.

64 bit system with AMD turion X2, 2 gigs RAM.
One harddrive, partitioned into 5 parts.
sda1 Windows XP pro NTFS
sda2 SUSE 11.0 ext3
sda3 MEPIS 7.0 ext3
sda5 is Home for both SUSE and MEPIS ext3
sda6 is another NTFS partition, holding games and stuff.

edit> and a swap partition

Ill start reading once this post is posted.


If you used the full DVD to install openSUSE (rather than the Gnome or KDE live CD) you can install the Grub bootloader with openSUSE’s rescue package which is accessed from a menu item about midway down the first screen when you boot off the install media.

There’s some more details here: GRUB Boot Multiboot openSUSE Windows (2000, XP, Vista) using the Grub bootloader.

Well I used the KDE Live CD.

So if I got the DVD? I might be able to fix it?

Obviously you can’t reinstall GRUB using the opensuse 11 live cd.

You’ll have to use the DVD.

You can also use the Super GRUB Disc bootable cd in order to repair/reinstall GRUB.

Yes. Alternatively use as suggested by (CurvyTail) some live disk and access the grub on that. Here’s a post wher that was done from the openSUSE 11 Gnome live CD:
Grub halts at “GRUB” no error - openSUSE Forums

Or, if your MEPIS 7.0 LiveCD is handy, boot it up, and go
to SYSTEM->MEPIS->SystemAssistant and click its
REPAIR BOOT tab, choose the MBR option, and it will setup
a grub that will be able to boot all three of your OSes.


Dave [another MepisLover]

To me during ve install you put Grub not on the mbr but in the root/boot partition. So i agree with sverdna

Yes. Very very important to check this, openSUSE 11.0 does not install grub to the MBR by default. Always check your boot configuration before installing.

Works now, thanks everybody :smiley: