grub installation problem when installing over Ubuntu

I have ubuntu and windows running right now in my pc and I want to replace ubuntu (keeping home). But the problem comes with the bootloader, when the system restarts the system goes to grub menu and just sit over there. Its not a perfect grub menu too, as i cant do grub update and all.
During installation of opensuse also some warning comes when configuring bootloader(did it 1.5 months back) that system might not be able to function properly due to some size constraint. I tried to install grub it in both root partition and MBR one by one but doesn’t work and the issue remained the same. this type of installation leaves the system paralyzed and i don’t want that.
However I am very much interested in using opensuse. currently Ubuntu’s grub is functional don’t know where it is installed.
If anyone can take me out of this then I will much appreciate the help.
Thanks all.

When installing openSUSE after Ubuntu, I install openSUSE’s Grub it it’s own partition and - important! - I prevent openSUSE from writing a generic bootcode into MBR]( (that would overwrite Ubuntu’s Grub). At the first reboot, Ubuntu’s Grub shows up and of course, it doesn’t contain an entry to boot openSUSE at this point. I boot Ubuntu, run update-grub in a terminal (see my example below)

$ sudo update-grub
Generating grub.cfg ...
Found background image: /usr/local/share/images/Ubuntu/ocelot.jpg
Found linux image: /boot/vmlinuz-3.0.0-13-generic
Found initrd image: /boot/initrd.img-3.0.0-13-generic
Found linux image: /boot/vmlinuz-3.0.0-12-generic
Found initrd image: /boot/initrd.img-3.0.0-12-generic
Found memtest86+ image: /boot/memtest86+.bin
Found Windows NT/2000/XP (loader) on /dev/sda1
**Found openSUSE 12.1 (x86_64) on /dev/sda10
**Found Fedora release 15 (Lovelock) on /dev/sda12
Found Debian GNU/Linux (squeeze/sid) on /dev/sda16
Found Windows NT/2000/XP (loader) on /dev/sdb1
Found Gentoo Base System release 1.12.13 on /dev/sdb6
Found Windows NT/2000/XP (loader) on /dev/sdc1
Found unknown Linux distribution on /dev/sdc18
Found unknown Linux distribution on /dev/sdc3

Then I reboot, select the entry for openSUSE - which should have been added - and proceed with openSUSE setup.

but i don’t want ubuntu, I want to replace it completely with opensuse keeping /home.
Will that be possible keeping Ubuntu’s grub and installing opensuse’s grub in /(i think not)?
there must be a way…

Oh, OK.Then just install openSUSE. It doesn’t matter where you install Grub. If you don’t install openSUSE’s Grub in MBR, it will write a generic boot code there and activate the Grub partition. If you install Grub in both location or only in the MBR, it’s OK too. It you keep the /home partition, I recommend choosing another login name.

I don’t know what’s causing the problem. You’ll need to tell us or inverstigate more. But instaling stage1 of Grub in both locations is usually fine. If you have the choice, MBR is safer (from a Linux point of view - but Windows users don’t like it for other reasons).

It is possible to do, But it’s not for the faint of heart!!!
Read ALL of this post before you even try this!!
If there is any part of post that you don’t understand then don’t do it!!!

you will need:
A copy of Puppy Linux – Puppy Linux
Your Windows XP install disc or Windows vista/ 7 repair disc

You didn’t say what version of Ubuntu or Windows you have
So I assume it’s Windows XP or better…
First you MUST back up your data on both the Windows
& Ubuntu Partition as you could & might very likely end
up wiping the drive.

With XP you boot the disc to a recovery console:
from the Command line (console) type fixboot and hit enter
then type fixmrb and hit enter.
input y to any prompts you might get.

With Vista / 7 you boot the repair disc
follow the prompts till you get to the
Command Prompt type fixboot and hit enter
then type fixmrb and hit enter.
input y to any prompts you might get.

At this point a reboot should boot Windows straight up without GRUB showing up.
If not you have messed up and may need your backup. If Windows booted properly then
shut down Windows to a system reboot using the Puppy Linux CD. (Boot the Puppy CD).
Mount the Ubuntu partition and you should be able to remove the Ubuntu files (But don"t touch your /home folder).
Install openSuse but “don’t” allow it to format any partitions and make sure the installer points /home to your old /home folder.
(you might need to use the custom partition option)
Use your old login user name and login name. If all went well you will be duel booting openSuse and Windows with all files intact.

note that Ubuntu uses GRUB 2 openSuse uses GRUB 1 Suse doesn’t recognize Ubuntu’s bootloader that’s the problem here.

I just noticed I mistyped the recovery commands
they should be:

With XP you boot the disc to a recovery console:
from the Command line (console) type fixboot and hit enter
then type fixmbr and hit enter.
input y to any prompts you might get.

With Vista / 7 you boot the repair disc
follow the prompts till you get to the
Command Prompt type fixboot and hit enter
then type fixmbr and hit enter.
input y to any prompts you might get.

Sorry for the messup on my part

Hmmm … If the goal is/was (?) to recover Windows bootloader, installing openSUSE with default settings will write a generic bootcode to MBR and activate the Grub partition. All you need to do after that is to set the bootflag on the Window partition using one of the fdisk, sfdisk, cfdisk, gparted, among others commands available on all Linux live CDs. Then, at next boot, you’ll have Windows booting. It is unlikely that the Windows bootsector has been damaged, unless you messed up with partitioning or installed Grub in the Windows partition … not 100% excluded but it’s an ‘uncommon’ mistake. However, the world has changed many times (for the worse) since the last time I used Windows.

We don’t.

True, however on duel boot rigs Ubuntu writes GRUB to the master boot record by default.
I have found myself looking at a GRUB error more times than I care to count when myself
or someone I know wants to change from Ubuntu to some other Distro (openSuse included).
It’s not a big problem if Windows is not to be saved or not on the rig to start with,
a change to the installer options will fix it. On the other hand if you need Windows then
starting with only Windows booting is a good option, if you know what needs to be done.
The fixboot and fixmbr commands from the Windows disc will do that for you.
I had to install openSuse 3 times before I figured out that Ubuntu had really messed up my MBR.
Later on I just backed up the drive and did a full install on an encrypted LVM setup ---- goodbye MS Windows :peace: ----

Yes it does. It has to. It wouldn’t be clever to install Grub2 bootloader somewhere else - possible but discouraged. See my post here:

Absolutely. But you don’t need them if you’re going to install openSUSE. Installing openSUSE with default settings (while it will put a generic bootcode in the MBR) is the equivalent of fixmbr. Everytime you install openSUSE, you’re doing a fixmbr. openSUSE (default) setup is nice to Windows and nasty to other Linux distros using Grub2. As for fixboot, you don’t need it either because the Windows bootsector (the first sector of the Windows partition, not the MBR) hasn’t probably been touched by anyone (unless you really messed up with your Windows partition - but none of the Linux or Unix writes in this bootsector).

thanks for the replies.
fixmbr stuff via window dvd looks cool and easy but I don’t have the dvd now

please_try_again, is it really required to set the bootflag first on the windows then do the install, while reading your comments it seems we can install opensuse directly as you said the mbr will be overwritten with opensuse’s grub so no need. is my assumption true.? if so then i need to find why last time everything went blank.

burning the dvd may be before another reply the expperiment will be over/

No. It’s only required if you want the Windows partition to take control - and so boot (only) Windows. I don’t think that’s what you want. I was actually just explaining (to @Lykopis) that you don’t need fixmbr - doesn’t mean that it doesn’t work, but you see, you don’t have a Windows DVD. Not to mention that there are Linux tools which are able to write Windows bootsectors: ms-sys.

Yes and no. Unless you uncheck some options and check other ones, the MBR will be overwriten with generic boot code - not with Grub. However you can install Grub in MBR too. It’s up to you:

What can I say? There are too many Windows users here. Ok, then I will say that generic code is fine. The Grub bootloader will be installed either in the Linux root partition if it’s a primary one, otherwise in the extended partition. The partition containing Grub will be set active (have the bootflag), the generic boot code will pass control to it and it will boot. So you will get a Grub menu, from where you will be able to choose between Linux and Windows. I you install Grub in MBR, you will get the same boot menu and the same choices. There are several possibilities which all have their advantages and inconveniences.


Yes. It might have been another problem or two unrelated but simultaneous problems.

here again i am left with a corrupt state.>:(

Disk /dev/sda: 250.1 GB, 250059350016 bytes
255 heads, 63 sectors/track, 30401 cylinders, total 488397168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x36e73395

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1              63    81915434    40957686    7  HPFS/NTFS/exFAT
/dev/sda2   *    81915496   488396799   203240652    f  W95 Ext'd (LBA)
/dev/sda5        81915498   249871881    83978192    7  HPFS/NTFS/exFAT
/dev/sda6       249872384   486318079   118222848   83  Linux
/dev/sda7       486320128   488396799     1038336   82  Linux swap / Solaris

here looking at fdisk-- the partitioner can’t find the /home neither / so i cannot explicitly mount each type of partition.
Please tell me what to do. I don’t want to format the system now

How come you didn’t post a fdisk output before installing?
How come we didn’t ask?

From where are you posting this output right now, live or installed system?

Notice that by default, Ubuntu doesn’t use a separate /home. Maybe that’s the problem: You never had a /home partition. Non formating it wasn’t possible in this case (or at least much more tricky than you would expect, I should say).

hmm, i was under the impression that there will /home separately as mostly i use suse. its from live system
so here i am.
while installing as there was no /home i pointed suse to /dev/sda6 but after copying almost all the root image
to disk it gave an error, so now ubuntu is gone but grub wasn’t written so ubuntu grub is intact and i can
open windows.

if any trick can rescue this situation then please let me know

You could have kept your /home but you didn’t have any. Sounds like a bad day.

As for the error you got, we don’t have enough info to say what went wrong. First thing to try is a media check, then a hdd check.