grub-install looking for a raid that does not exist


I’ve been tasked with fixing a ~12 years old server where the software mdadm RAID has failed. Long story short, both hard drives are effectively dead. Luckily, I have a backup of all of the files.

I recreated the partition structure of the original drives (system/data/swap) on a single SSD - no RAID. Booting this has failed, likely because the GRUB files at the start of the disk (we are working with MBR partitioning here) were not backed up. I thought, no big deal, I’ll just re-install GRUB by chrooting from a live USB. This, however, has proven tricky.

I edited fstab, deleted the mdadm configuration file and deleted the /boot/grub folder entirely. I ran an mdadm scan to make sure it would not detect the drive as a raid disk. However, somehow, I still get the following error:

grub-install /dev/sda --recheck

Probing devices to guess BIOS drives. This may take a long time.
/dev/md0 does not have any corresponding BIOS drive.

There is no /dev/md0 and every configuration file I have checked has no mention of there being one. I spent 4 days trying to figure out where it is getting this info from, with no success.

Does anyone know what makes it think there is a /dev/md0? Especially when I am trying to install GRUB to /dev/sda

PS: I cannot just reinstall the OS, there is a very specific Intel Fortran install on this os that nobody involved knows how to reinstall.

Hello and welcome to the openSUSE forums.

You choose OTHER VERSION from the prefix of the thread title. That means of course that you then first and for all mention what that other version (none of the supported versions) is.

Now nobody has any idea how far back they have to go in their minds to try and understand your environment. Something that is often crucial in helping someone.

Another thing that you could not know is this:

There is an important, but not easy to find feature on the forums.

Please in the future use CODE tags around copied/pasted computer text in a post. It is the # button in the tool bar of the post editor. When applicable copy/paste complete, that is including the prompt, the command, the output and the next prompt.

An example is here: Using CODE tags Around your paste.

Was the original RAID fake or hardware. If fake then there maybe a BIOS switch turning on the software assisted BIOS routines (FAKE RAID)

The version I’m working with is SUSE Linux Enterprise Server 10 SP 1.

There is no relevant setting in the BIOS. The original RAID between the two dead disks was made using mdadm.

I’m thinking there is a config file somewhere that specifies the OS was originally installed on a RAID, however I have no idea where that could be.

So it is not even openSUSE!

Again, people will try to help you, but this is not a SLES/SLED forum.

Oh man, sorry for the trouble, I’m not very knowledgeable on this topic. I did not even know the two were a different thing.

This is just a wild guess (i use openSUSE Tumbleweed and boot my system in UEFI-mode):

If you are booting in MBR-mode and you have a file /boot/grub/ it might be worth checking it.