Grub hell. Anyway to kill it? rip it our of my pc with no mercy?!


First of all yes I was that stupid.
It is a very common issue that I see is present since the times Grub was introduced.
I guess you already suspect it.
I was naive to believe that boot loader is placed somewhere in the installation directory of Linux and using partitioning software on Windows I formated Linux partitions.
Now I am stuck with Grub rescue > thing.
There is a lot information about the trouble, but mine differs that I can;t load any CD or dvd. regardless of bios settings, it is just ignored. I can boot only from one specifix USB key, all others doens;t boot either. The nice Linux I erased was based on Ubuntu, since I decided to go back to OpenSuse (I am partially migrating to Linux anyway and form my experimentations OpenSuse is the most solid one) And while I had important rendering process going on I decided to use that 30 mins and format the partitions.

The most interesting thing is that no other Linux OS except OpenSuse will boot. I fallowed the steps of creating Live USB related to the Linux I erased, no boot, I tired other Linux OS - no boot, only openSuse will work. Unfortunately what ever I do, even after successful installation of OpenSuse I get the Grub rescue >
it won;t accept any commands except Set.

I no longer have any other OS except OpenSuse because I tried to do a master level formating, erased all partitions merged all into one and created one prime partition to which I installed Opensuse.Still nothing has changed.
The only way I can boot to live OS is to use the only one and no other USB key and it will work with OpenSuse Only.
But I need to install windows because i have a job project that I need to accomplish using software available only for Windows and MAc OS X.

Is there any tool to wipe out grub and set booting to default one using openSuse Live USB?
Seeing how many times and for how many years people are getting into similar situations, Grub devs should have addressed it and make grub load to second or third OS available on HDD if the prime one is missing.

Could anyone help me please?
I will try to boot Kubuntu and see if it can override grub, but from 6 different Linux boot attempts it looks like only OpenSuse can boot and only on the precise USB key, the other one I have is ignored too, but it works fine on another pc and boots everything.

Thank you very much in advanced for your help!
Best regards,

Hello, Sorry to hear of your problems -but- I at one time … not to long ago … had similar problems. You can read about them at:
Starting Over and maybe something will be there that will help you. In conjunction with that, there is a program called “SuperGrub” that I have used many times to get my grub straightened out again. However, from the sound of things it appears that you have wiped all systems from your hard disk. Still this may help … along with the other programs and advice that I copied and/or supplied on the previously mentioned WebPage. Link to SuperGrub is on my WebPage…(need to get somebody to read it)
Take care,


First, take it easy! It is tricky, even complicated, when you don’t know exactly how openSUSE setup handles the Grub installation and how Grub works in general. Notice that the Grubs used in Ubuntu and in openSUSE are two different programs.

  • First point: You don’t have to reinstall operating systems or remove or reformat partitions. The problem basically only involves the presence of Grub stage1 in bootsectors (the very first sector of a partition) or in MBR (the very first sector of the hard disk) as well as which of the four primary partition has the bootflag.
  • Second point: The fact that you can not boot from CD/DVD is not related with Grub installed or not on your hard disk. Remember this unwritten rule applying to computer hardware and computer systems (and most people as well): there are always two different problems occuring at the same time.

I personally find openSUSE’s Grub installation ‘policy’ unacceptable for a Linux (Don’t worry! I like other things and no distro is perfect) and I’ve explained why on many occasions. However, despite my ‘rants’, openSUSE developpers and users love it that way and it’s probably never going to change … until Microsoft ceases to exist, then maybe they might consider giving the boot preference back to other Linuxes rather than Windows.

What you should know when you install openSUSE on a computer where Ubuntu or another Linux is already installed with Grub in MBR is that openSUSE will show no mercy for the bootloader and overwrite it with a generic bootcode, just like Windows does. However this doesn’t mean that you can not change the default behaviour. Here’s how to do it:

  • always choose “Create partition setup”, the first option in 11.4 (was actually the third option in previous version) and then expert mode, select the partitions you want to use for openSUSE and format them if you have to. Notice that the reason not to format a partition is because you want to keep the data on it and NOT because you previously formatted it using Windows software. In that case, you should rather reformat it anyway.

  • You have to prevent openSUSE to write a generic boot code to MBR by clicking on “Booting” at “Installation settings” , then open the tab “Boot loader installation”, then click on “Boot loader options” an then uncheck “Write generic bootcode to MBR”.

  • That might not be possible if you didn’t unckeck “Use automatic configuration” at the beginning of the setup. I don’t know since I would never got the idea to use automatic configuration for anything.

Is that complicated? Well, for some peopple, I could imagine it is. Why is that magical option hidden behind so many clicks? I have no idea (Maybe Steve Ballmer would know. ;))

Look at the pictures I posted here for 11.4: Comments on installing openSUSE 11.4 and here for 11.3: (net-)installation on a multi-boot system: MBR overwrite]( *

You might also want to take a look at this slide show. It describes the installation of openSUSE 11.4 in a virtual machine, but the Grub installation procedure is the same as on physical computers: openSUSE 11.4 - vm installation guide

Good luck.

  • It hasn’t change though.
    ** You’ll find many posts on how to reinstall Grub in this forum. It’s not complicated.

If you don’t have grub in the mbr you’ll leave Windows bootloader there and then have to use another software to boot any other operating system. It’s Windows that’s the problem, not grub.
I have Grub2 booting all my operating systems (6 of them) with no problems at all. When installing openSUSE I installed grub (legacy) to the root partition, not the mbr. That way it left my Grub2 installation alone. I then updated grub2 in the controlling operating system, which picked up 11.4, allowing it to boot.
The point is that something has to be in the mbr - either Windows or grub/grub2, or nothing will boot.
With a bootable Windows repair disc you could have repaired the mbr and made Windows bootable again. (Or installed lilo from a live cd).
Have you tried returning your bios settings to the default setting (the option should be there) and tried booting from cd/usb?
It’s a bit late now though, unfortunately.

Nope. Windows is NOT is the MBR. Windows expects a generic boot code in the MBR. That’s the reason why openSUSE puts a generic bootcode there if you don’t tell it explicitely not to.

Provided you also set the bootflag back on the Windows partition which has been deactivated in favor on openSUSE’s root partition or the extended partition (if the root partition is a logical and not a primary partition). Of course a Windows repair disk would do it - among other damages.

Yes. Notice that this feature is only present in Grub2.

Windows in the mbr is just a figure of speech which negates the need for lengthy explanations.
The Windows “generic boot code” can be replaced with lilo, or by running bootrec.exe /fixmbr from the command prompt in the Windows recovery console on a repair disc. Either of these do no other “damages” at all. Admittedly they will necessitate the re-installation of grub/grub2 to make other Linux operating systems bootable again.
The boot flag should be where it always was, surely? Linux systems don’t use the boot flag. That’s a Windows thing.
Your last comment is the reason I didn’t let grub legacy anywhere near the mbr on my discs. Maybe it’s time for openSUSE to adopt the newer version?

A figure of speech is not appropriate in this situation.

Who else is still using lilo noawdays? From which century are you talking from? BTW the Windows command to repare the MBR varies depending on Windows versions. Alternatively there is a Linux program which can rewrite Windows like MBRs. It used to be available in several distros but has been retrieved due to legal issues: ms-sys

That was a figure of speech (also refering to the damages inflicted on your brain by using Windows.)

Nope (Unfortunately!). OpenSUSE setup by default sets the bootflag on its root partition or on the extended partition. It also sets the bootflag on ist root partition, even if that one it is a logical partition - which is neither a Windows nor a Linux thing but just a nonsense. (I’ve seen Fedora doing the same).

Your last comment is the reason I didn’t let grub legacy anywhere near the mbr on my discs. Maybe it’s time for openSUSE to adopt the newer version?

Grub2 has other problems.

  • It doesn’t always parse correctly Grub menu entries from other distros, which may use different syntax. It works well with openSUSE and Fedora but doesn’t get Mandriva and derivates properly. In such cases, you have to edit grub.cfg manually after running update-grub or modify the syntax used in menu.lst on Mandriva’s side.
  • The worst thing: it insists of scanning Unix partitions it cannot read, which results in an endless loop and installation of Ubuntu (Maverick) fails on such systems, although previous versions of Ubuntu installed fine.

lilo can be installed via a live cd to enable Windows booting, if, for instance, the user does not have a Windows repair disc.
With regard to the boot flag, I can only comment on my system, on which the boot flag was left alone on the Windows 7 partition after several Linux installs.
However on the second hard drive (which was a clean drive) a boot flag appears to have been created by openSUSE and placed on its root partition. This may be because some bioses won’t boot from a hard drive that doesn’t have a boot flag.
Grub2 is being constantly updated. From memory I think the current version is 1.99. I have Lucid, Maverick and Natty Development Release installed and have had no problems at all with any of them in relation to Grub2.

It would have appeared there too even if you had had a Windows primary partition active on that drive. That’s actually the purpose and pride of openSUSE’s boot strategy. Ubuntu doesn’t do that because it installs Grub in MBR and therefore doesn’t require an active partition… with the side effect that if you have none and overwrite Grub in MBR with a generic boot code (as openSUSE setup does), without knowing exactly what you are doing (like most beginners from Windows background), install openSUSE in a logical partition (just to be clever or because you don’t have another choice), let YaST activate this partition (because you don’t mind) but prevent it from activating the extended partition as it intends to do (because you don’t understand the concept and it looks scaring)… guess what happens?

There aren’t problem with any of them - if you read what I said. If you were multibooting your Linux with any BSD and so had a 0xA5/0xA6/0xA9 partition, you would have experienced Maverick’s installation on those machines and you would have been happy to have a Linux distro still using Legacy Grub.

  • I don’t get the lilo thing. I haven’t used lilo since last millenium. Speaking of oldies, what about loadlin on the MS-DOS prompt? It used to work great. :wink:

I have 3 Ubuntu Live.iso’s,a gparted.iso and a clonezilla.iso all booting from the Grub2 menu, instead of from the actual live cd/usb. They boot in 40-45 seconds to a usable desktop. That may be possible from a grub legacy menu, I don’t know - but I’ve never heard of it. It is one huge advantage with Grub2.

Regarding lilo, imagine a system dual-booted with Windows 7 and Ubuntu, for instance. For whatever reason, the mbr gets corrupted, so neither system will boot. The user has a Ubuntu live cd, but no Windows repair cd (because he didn’t even know he could make one). A common enough situation, in my travels. The user is not worried about the Linux system. He just wants all his Windows system back, because his big brother will not be pleased with him :slight_smile:
If he loads the live cd, gets an internet connection, he can then install lilo to the mbr and his Windows system is then bootable again. He doesn’t have to move the boot flag with gparted, or diskpart, because Ubuntu never touched it. Panic over - he can fix Ubuntu later.

Wow this is what I needed!
I had a feeling to try Lilo but wasn;t sure if it was safe things to do so I went the bad road.
My situation is exact as described except that I knew about recovery discs but I never make them. I store my Data on external HDD. So I do not worry much about Windows.

The problem was that once I made the stupid partitioning using alternative software I lost my way to any OS and CDs won;t boot, and not all of the USB keys, regarding DVD room, I suspect issue might be with it beccause lately it began to be unable to read many CDs and DVDs it would consider them to be blank ones when they really are not blank. But I was able to instal Win 7 not so long time ago. So it has to be some odd things happening to not boot from the DVD Room.

Unfortunately it is too late for me to try Lilo, but the good news are that I was able to isntall Kubuntu and it boots. Now I have to figure out how to make windows dvd boot. Pitty Linux available software doens’t provide suitable alternatives for me. There are so many tools looking at the right direction but they jsut don;t go the road…

But now I have second thoughts about OpenSuse. It appears the setup is really very predefined regarding partitioning, with Kubunu I was able to pick entire HDD while Opensuse gives me at least 4 parts of partitions that I thought I merged into one but not. And the most strange thing OpenSuse steals 10GB of my HDD. Kubuntu shows me all 160GB while OpenSuse Shows me that my HDD is 149GB, Why is that so?

Now I am a bit lsot what to choose, i am migrating partially Linux anyway, I have software package license that is meant for Linux OS and I woudl also like to try out Houdini 3D app. It is not a msut do thing but I see that OpenSuse isn;t listed as supported OS in many comemrcial software providers that I may have to use if I go completely Linux.

Thank you very much for your help and taking time to give me and I supose many other people hints when on Grub problems. So much information.

Oh one more detail would be nice, While I was in a search of how to fix it on my own, I tried to isntal Grub 2 via live CD of OpenSuse, butI suppose I really was doing sometihng worng becasue there was cpletely no effect to the system, it would be nice if someone could provide steps on how to isntall boot loader for it to be effective, just in case.

My aplogize for spelling mistakes, this browser doesn’t have spell checker!


Thank you very much for your link!
I did only a fast read but I can tell it is a good read.
I have tried the super grub application before I posted this thread.
However the result was “disk error press enter to restart”
I believe I fallowed the isntruction provided with the downloaded readme file. But I suppose I did sometinhg incorrect.

I think there should be a sticky thread about grub and it should contain the link to your article. Less threads by peopel like me would emerge in the forums :smiley:

A day after your disaster I suffered a similar fate (it was posted as <OpenSUSE 11.4 's Grub Eliminated Access to Mint 9>) but while I lost access to my main OS (Mint 9 64 bit Gnome) I didn’t erase any partitions.

The replies posted here and to the Linux Mint forum included links that led me to:

Boot Problems Open Source Tools | Super Grub Disk, Super Grub2 Disk and Rescatux

where I downloaded this:,

which put me back into LinuxMint 9 after choosing the third option:

“Detect any Grub2 installation (even if the mbr was overwritten)”

This did NOT reinstall Grub2 (and I was unable to reinstall Grub2 with “grub-install” etc or “sudo grub” but also has another application called Rescatux, which (they claim):

* Fixes GRUB
* Fixes GRUB2
* It cannot boot on other systems (only Rescatux itself)
* Regenerates grub menues (Only in Debian/Ubuntu systems)
* Check filesystems and fix them

and I intend to give it a try after backing up my Mint 9 partition (which I am using at the moment).

So unless you’ve erased your partitions, you can recover access to your previous Linux Distros and Windows.

I will never install another version than requires using Grub Legacy (which OpenSuse doesn’t) and can’t accept the fact that OpenSuse doesn’t warn about this during installation.