Grub hangs indefinitely after grub restore (lvm encrypted drive)

Hi I’m stuck and can’t boot into opensuse 42.2 Leap installed on a single drive with encrypted lvm partitions

Problem when booting the grub boot loader displays…
Grub Loading
Welcome to Grub!
_ (cursor blinks forever, and no input is accepted Esc, ‘e’)

The boot loader was overwritten by a Ubuntu install on a separate disk something several Debian installs did not do. I have attempted to restore/rebuild grub2 by using rescue but the result is always the same, grub just hangs immediately on boot.

I performed the following steps in rescue and grub was rebuilt reporting no errors (also detecting suse kernels and other OSs on other disks)

cryptsetup luksOpen /dev/sda2 cr_lvm

<found valume group “system” using metadata type lvm2>

vgchange -a y system

<2 logical volumes(s) in volume group “system” now active


<ACTIVE ‘/dev/system/home’ inherit
<ACTIVE ‘/dev/system/root’ inherit

mount /dev/system/root /mnt
mount /dev/sda1 /mnt/boot
chroot /mnt
mount -t proc proc /proc
mount -t sysfs sysfs /sys
grub2-mkconfig -o /boot/grub2/grub.cfg
grub2-install /dev/sda

Additionally, I’ve tried to “upgrade” through the install disk, and use Yast to write write the bootloader, no errors are thrown. I’ve tried mkinitrd which does list output that it recognizes LVM partitions, but the result is always the same immediate boot to hung grub.

If anyone has any ideas, or hooks I may need in the boot loader, or even other sources to look for answers it would be helpful for me, Thanks

I was able to boot by reordering the drive order in the BIOS, I’m unsure why this works because the OpenSUSE is sda, the first drive in fdisk -l as well as the boot menu.

when attempting to login it now says “Could not start D-bus. Can you call qbus-qt5?” in a window in the top left without letting me login a top left but this is a different issue than the grub problem mention, (probably a side effects of all the things I tried, when I could have just reordered the disks)