Grub halts at "GRUB" no error

I started with the following setup:
HP dv5035nr, 1.5GB RAM, Radeon XPress 200M, 74GB drive
booting managed by System Commander 9
/dev/hda1 30GB Primary partition for XP MCE SP2
44GB extended partition
/dev/hda5 11GB NTFS logical drive
/dev/hda6 20GB ext3 openSUSE with GRUB installed here
/dev/hda7 12GB ext3 Kubuntu 8.04 with GRUB installed here
/dev/hda8 500MB swap

I booted to System Rescue CD and launched GParted.
I shrank hda6 to 10.2GB and then moved hda7 to bump it so that free space was after hda7 and before the enlarged, to 2.4GB, swap area. I intend to grow hda7 to include the empty space.

I left the empty space there to ensure everything was kosher.
-booted into XP. OK.
-booted into Kubuntu. OK.
-booted into openSUSE
FULL STOP. All I see is “GRUB _”.

I booted with the System Rescue CD and in the terminal I type grub to get a prompt:
grub> find /boot/grub/stage1
**Yes, that’s correct. That’s the Kubuntu partition.
grub> root (hd0,5)
Filesystem type is ext2fs, partition type 0x83
grub> setup (hd0,5)
Checking if “/boot/grub/stage1” exists…no
Checking if “/grub/stage1” exists…no
Error 2: Bad file or directory type

So nothing usable there. Before I boot into Windows and do a restore from Ghost 14 (partitions backed up to an external USB drive), is there anything anyone can tell me about what happened and what I can expect with enlarging hda7? I don’t really care about the openSUSE partition as it’s in such flux a reinstall is OK but I really don’t want to have to re-setup the Kubuntu partition. I know I have a backup of that, too, but I’d rather avoid the hassle if I can.

So, any ideas what happened with resizing the partition and fubaring the boot setup in the openSUSE partition?

I think this is right:
You’ve got Kubuntu on hda7 and it still boots OK with system commander.
You need to restore booting to hda6,sda6,(hd0,5) but Grub won’t install there at the moment.
I’m assuming openSUSE 11.0 here, even though you talk in terms of earlier kernels with hda terminology

If I’m right then boot from the Suse install DVD and on the first screen select to repair the installed system. Wait for the screen with three choices and select “Expert Tools”. Then click option “Install New Boot Loader”. Select the partition where you installed Suse (if asked). You’ll get the Grub GUI setup screen. Check under the Tab “Boot Loader Installation” that the checkmark is in “Boot from the root partition” and remove any other checkmarks. Click “Finish”. Wait for message “The boot loader was installed successfully”. Click OK → Next → Finish. Ignore any error messages and reboot.

At this stage you get System Commander to point to the root partition of openSUSE 11.0 and it should boot.

Yes, it’s openSUSE 11. It boots 2.6.25.something and uses sda while Kubuntu is currently booting to and uses hda. It does get confusing. Anyway, I’ll try the repair thing with the openSUSE live CD. Thanks.

OK, I booted with the Live CD and the first screen does not have a Repair option. It has:
Memory Test

I tried the first option but it just goes into the full boot and the only option then is the install icon on the desktop and that starts the install wizard.

Selecting Hard-Disk just takes me to System Commander (I figured as much but had to try it.)

I don’t have the DVD, just the install CD. I guess I’ll have to start the download for the DVD huh?

Alright, that’s just weird. According to the install live CD HTML doc, I should see:
Boot from hard disk
Repair installed system
Rescue system
Firmware test
Memory test

I’ll grab a new Live CD ISO first and try that before trying the whole DVD route. And I’m sure I’m using the released ISO and not the RC1 iso…

FYI, I’m talking about the KDE4 Live CD, not the Gnome CD. I’ll grab both. Strange, though, that the KDE4 Live CD I already have is nothing like the Gnome one. No repair option.

For the sake of closure:
weird. weird. weird.
I’m downloading the GNOME Live CD anyway, cuz it’ll be handy to have on hand.

So. I must have run GRUB> find /boot/grub/stage1 without properly mounting the openSUSE partition while running Kubuntu. Just now, I opened the openSUSE partition from Media and authenticated to mount it. Once it’s contents appeared in Dolphin and I could verify there was indeed a stage1 in /media/hda6/boot/grub, I ran the grub commands again.

sudo grub
grub> find /boot/grub/stage1

That’s both of them. Since I know openSUSE comes first, I did the rest:
grub> root (hd0,5)
grub> setup (hd0,5)
grub> quit

Then I rebooted and selected openSUSE from System Commander and all is well again.
UPDATE: Well, it’s OK when I have the 8GB SD card slotted since it’s mounted by label “Backup”.

OK, you’re in and can fix things – great.
That’s weird about the KDE CD – I just checked mine – no repair option either.

I must make a note of how to get into Suse your way – thanks.