I’ve just been through the process of installing openSuse 11.2. I installed grub to the MBR, but when I tried to boot from the hard disk I didn’t get a menu, just the word GRUB repeating on the screen and scrolling. After much googling I found a solution and I’m posting it here to help anyone else who encounters the same problem.

To resolve the problem I did the following

  1. booted from the install DVD and started the Rescue System

  2. at the Rescue login prompt typed root and hit Enter

  3. at the rescue prompt typed grub and hit Enter

  4. at the grub> prompt typed the following commands (hitting Enter after each)

    find /boot/grub/stage1

It returns e.g. (hd0,2). These disk and partition numbers are used in following commands. Substitute whatever values you get when you run the find command yourself.

  root (hd0,2) 
  install (hd0,2)/boot/grub/stage1 d (hd0) (hd0,2)/boot/grub/stage2 p (hd0,2)/boot/grub/menu.lst

Finally reboot from the hard disk and the menu should now work properly.

Hope this helps someone

Hmmm… tried it exactly as you mention above, and nada. Still comes up to the grub> prompt. GAAAAA

Instead of latching onto all sorts of old forum messages, why not post your own real problem help request, in Install/Boot perhaps, if you can’t get your PC to boot after installing openSUSE? To get help, you need to ask for it and stop complaining everywhere in the forum about a problem we have not been allowed to fix.

Consider this to be a warning on the subject.

Thank You,