GRUB error - new install won't boot

Here’s hoping someone can help me with this :).

I have a Dell XPS 400 with an Intel 945P chipset motherboard, and a Western Digital 160GB SATA hard drive. On Sunday, after backing all the data up from the original Windows MCE OS, I put the 11.1 32-bit install DVD (burned the day before) in the drive, and installed it as the only OS. It created three partitions - from memory, swap/root/home - and I let it install its recommended set of software, using KDE4.

After the install was completed, I was able to login to the system without trouble. However, after rebooting, I got this error:

“Error 25: Disk read error”

I tried booting from the DVD again and running the repair option. It found the third partition (/home, ext3) was corrupt, fixed it (twice), then found a problem with GRUB, fixed that (twice - and yes, it’s installed to the MBR), then allowed me to re-boot.

Same problem - error 25. Ran the repair again with the same results, and again I get an error 25.

I have since re-installed the OS perhaps five times (a couple of times with the 64-bit version DVD with the same result), every time with the same result.

Is this a problem with the hard drive, the DVD (I don’t believe this can be true as it happens with two separate DVDs, one 32-bit, the other 64-bit), the motherboard, the BIOS setup?

Any help most gratefully received.


  1. When the error message ocurres, did you hit enter and get the grub prompt? Do you know how to handle with grub commands?

  2. As you are well trained in reinstallation ;), what about reordering of the partitions: try root/home/swap?

Thanks for the reply!

I have on the odd occasion hit enter, but have not tried anything serious with the grub prompt. I can handle the commands, but really am not familiar with them yet.

:). I’ll reorder the partitions and see what happens from there - thanks for the suggestion.

I’m also going to try (as my machine has a ridiculous BIOS RAID setup which gives me no option to turn it off) an LVM setup. Some searching turned up some cases where the BIOS was flaky enough to interfere with grub.

Many thanks!


UPDATE: Thanks to your suggestion vetti, I fiddled with the grub prompt. It turns out that it was pointing at the wrong disk (hdb1 instead of hdb0).

So, thank you! I greatly appreciate the pointer :).