Grub - Error. File "normal.mod" not found. [SOLVED].

**Grub - Error. File “normal.mod” not found.

**I got this error after installing Leap 15.2. Followed all the advice on the net about using the Grub rescue command line editor to set the correct location of the Grub bootloader. Nothing worked.

The problem is in fact caused by the automatic selection of “Grub2 EFI” as the boot loader type during the installation rather than “Grub2”.

The easiest way to fix this problem in the context of a new installation is a reinstall. Go through the install options until the installation overview page is displayed and then click on “booting”. Select Grub2 instead of Grub2 EFI. Then confirm the installation.

The issue is probably cause by PCs reporting UEFI Bios instead of Bios to the installer.

The installer can be booted in either UEFI mode or in legacy BIOS boot mode.

If you booted the installer in UEFI mode, then it defaults to setting up your system for UEFI booting.

Since you have indicated that this is SOLVED, I’m assuming that you did the reinstall and now have it working.