GRUB Error. Can't find partition.

Have a good day and night.
I download dvd iso and install suse from it, everything goes fine, but grub. I get error “can’t find partition”. I try to use other partition for it, but with the same result.
My hard drive have GUID table, not MBR (macbook pro) with 5 partitions, and grub don’t see them. I use rEFIt to boot up.
I try to use Suse Gnome Live CD - with the same result. Also i try to use “repair system”, then install bootloader, but it also don’t see my partitions.

So, any advices welcome. Please.

Same here, not on a mac, but I have a jmicron controler ^^

same here … Fedora9 installs GRUB flawless on the /boot partition.
The openSUSE 11.0 install fails on installing grub. Tried booting in rescue-mode, mounting the partition and doing a manual GRUB install, but a ‘GRUB> root (hd0.2)’ doesn’t even find a valid location.

Same here. Using P35 chipset, OpenSuSE install hangs at GRUB install. I don’t have problem wih OpenSuSE 10.3.

I found solution in wiki: Installation on MacBook Pro Intel (x86) - openSUSE

Everything works fine.