Grub Error 22 without Vista

I am not dual booting, I only have one “drive” though it is raided. I have reinstalled both OpenSuSE 11 and Grub many times with the same results.

Every time I install I make it all the way to first log in then it either freezes after logging in or freezes before I can log in. After rebooting I receive a grub error 22 after stage 1.5.

I have tried reinstalling grub on the MBR and the primary partition. I have attempted to recover several times with each time the recovery says that everything is in good shape.

I have tried both ext3 and reiser fs types.

Although I was originally running 10.3 on this box I am doing fresh installs each time without choosing the default partitioning scheme but making my own based off of the same previous style.

Any help would be greatly appreciated,


Grub Error 22 : No such partition
This error is returned if a partition is requested in the device
part of a device- or full file name which isn’t on the selected

This suggests to me a grub configuration error. It might be helpful to see the output of fdisk -l, the partition and mount point information from /etc/fstab, and the menu entry from /boot/grub/menu.lst.

PS: quotation is from “Solving Boot Problems with Grub - 2nd Edition”

Everything in grub is pointing to hd0 and fstab looks normal. fdisk returns the boot partition, swap, and root as per expected. They are all reading as the same sda.

LILO doesn’t work either. Here is my real problem now that I think about it.

I have 2 raids on this system. One of which must be first on the chain or it will not work. Linux can not see this raid without the drivers which will not install on installation boot so i need to install the OS and then compile the drivers into the kernel and it will see the raid.

This raid, I believe, has the original grub information from my 10.3 installation that didn’t have any problem with the above mentioned maneuver. I believe this since I installed LILO and I’m still getting the grub error. (no grub yet a grub error).

How shall I go about getting rid of grub on the currently inoperable until I can get into my OS which can not happen while I have it connected since grub is installed on it and it must be the first on the chain to even run.

Not sure how to approach this one here.