Grub error 22 during install

I am loading suse the first time, since it is my first use at it. I have a macbook, with a dual core 2.2 GHz by Intel. I have my hard disk partitioned with Leopard (macos X, and windows xp) But I have about 100 GB of unpartitioned or unused space. I tried loading suse into that partition and I got this error. Here is the message.

GNU Grub version 0.97 (640K lower/3073K upper memory)
[Minimal BASH-like editing is supported. For the first word, TAB lists possible command completion. Anywhere else TAB lists possible completions of device filename.]
grub> setup --stage2=/boot/grub/stage2 (hd0,4) (hd0, 4)

Error 22: No such partition

Any suggestions of what to do?

my partitions were as sd4, sd5 in suse during the installation before it quit.


Same here. Tried install both grub and lilo from rescue mode (chrooted to hdd install) … but still unable to do anything from the grub prompt … “E22 no such partition” when doing things like ‘GRUB> root (hd0,2)’.

Strange thar grub prompts for ‘no such partition’ when /dev/sda3 (my /boot) mount flawless.

On fedora9, with the same partitioning-schema, grub installed without any issues.

I don’t want to install any fancy bootloaders like rEFIt … a bootcamp/grub combo should suffice.

rgrds, martijn

Same here. Tried to dual boot XP with SuSE 11. The system spec are:

AMD X2 6400
2 gb ddr2
2 320 Gb HD’s (both are sata, 1 has XP the other is extra for back up)
1 160 Gb HD IDE

Now I wanted to install SuSE on the other 320 Gb drive and leave XP by itself and got this error as well.

bumpity bump bump.


'Have same error messages

"GNU GRUB version 0,97 (640 lower/3072k upper memory)

[minimal BASH-like line editing is supported. For the first word, TAB lists possible command completions. Anywhere else TAB lists possible completions of a device/filename.]

grub>setup – stage2=boot/grub/ stage2 (hd0,1 (hd0,1)

Error 22: no such partition
grub > quit"

Config :
AMD Athlon™64 Processor 3000+ 1,81 GHz
Mem. 3,00 GB
Maxtor 6L250S0 SATA (WinXP Prof)
Maxtor 6L250s0 SATA
Silmage SCSI Disk Device (467GB - from RAID0)
Maxtor 6Y200P0 IDE

Try to install SUSE 11.0 on 200GB IDE device with GRUB to dualboot with WinXP on 250GB SATA device. GRUB chooses to install on Silmage’s MBR though (no OS installed at all ??!!); unable to select alternative but /dev/sde1 -sde3 (which are used for SUSE’s boot, swap and home) all of them concluding in same errors when chosen.

Initially job seemed to be not to difficult with SUSE 11.0 installation fron DVD. As I am Linux noknow, I waited for this opportunity, but I asume still bit to complex for me. But maybe someone can help me with easy hints???