grub error 18

Just installed suse 11. When I tried to boot up I get grub error 18. When I try to boot off live cd and choose ‘hard drive’ I get the same grub error.

Looks like an install far up on a new drive in an old computer. Is that right?
Link here:
says this:

Error 18: Selected cylinder exceeds maximum supported by BIOS
This error is returned when a read is attempted at a linear block address beyond the end of the BIOS translated area. This generally happens if your disk is larger than the BIOS can handle (512MB for (E)IDE disks on older machines or larger than 8GB on others.). In more practical terms this means the BIOS is unable to start executing the kernel because the kernel is not located within the block it can access at boot up time.

This can be circumvented by creating a boot partition at the beginning of the disk that is completely within the first 1023 cylinders of the harddrive. This partition will contain the kernel.

Do you have an install DVD for 11?

I have had a nightmare trying to install openSUSE 11.
GRUB Error 18 is only the peak of the trouble, allow me to include the full story:

  • The PC was running SUSE 10.1 and GRUB used to boot it from /dev/hda3 which is 1/3 of a 80GB disk.

  • I decided to keep the working installation and set up a parallel one on a different disk.

  • As a side-note, openSUSE 11 made a rather primitive impression when using plain VGA console mode while SUSE 10.1 was implicitly running a nice high-resolution console mode.

  • Installation suggested to delete and repartition /dev/hda3, my working 10.1 installation.
    Although there is a techie-style warning later in the workflow, on this page with the suggested partioning, there was no warning or even hint that this would of course destroy my previous data and installation.
    Very poor behaviour.

  • So I set up a partitioning in expert mode, keeping all partitions and installing into an existing 250GB partition.
    Now this gave me a warning as if I had tried something despicable! Though there is not really much trouble to expect from this approach, compared to the suggestion I had to discard!

  • This may already be related to the GRUB problem:
    After installation, when trying to boot the system, it complained about some obscure disk problems which I should manually repair.
    It did not mention, however, which disk and which problem.
    It did not give any hint either how to repair the problem.
    It just brought me to this console recovery mode from which I had to fiddle through man fsck etc.

  • Note: Console repair mode (or emergency mode?) does not apply local keyboard layout.
    This is very uncomfortable and annoying.

  • I tried the next step first, then applied some minor fsck repairs but nothing changed, so this is not the problem.

  • Trying to boot the previous 10.1 installation really upset me:
    GRUB Error 18! System not working anymore although I left it carefully untouched!
    The partition was still fine (verified by manual mounting in console emergency mode).
    This cannot be explained as above and found elsewhere on the Internet -
    because the system had been booting 10.1 fine for 2 years and I did not change the partitioning of the disk.
    So obviously yast of openSUSE 11 is not able to properly set up GRUB even if it finds a working one preinstalled on the disk.

Fortunately I was able to recover my system by doing a 10.1 repair installation, going some weird detours, however.
I don’t think I’ll ever again try to install SUSE 11!

Dear Sir:

I was amazed at the extent of the painful difficulty recently experienced by you when attempting to install OpenSUSE 11. No one should have to endure such things. It is truly regrettable.

My personal experience with SUSE 11 was much more pleasant than the one you related. However, I was always having difficulty in past days with installing 10.1 and keeping it updated and never kept it long because it was truly horrendous, the consequence of a primitive attempt to use part of a broken shovel as an updater, I suppose.

However, I commend you for being able to run and maintain a SUSE release from more than 2 years ago.

I have been using SuSE since ---- and have never seen a SuSE partitioner in the install process not warn of the consequence of lost data. Of this I am quite assured, that SuSE always did that in the past and SUSE, under the guidance and leadership of Novell, itself under the financial support of the giant Microsoft, follows the same procedure.

I must also note with great admiration that you wisely selected “expert” at the partition, ignoring the evil and felonious advice of the installer regarding the disposition /dev/hda3. The installer, as you discerned, obviously was attempting to lead you astray and destroy the beautiful and not-primitive high-resolution console mode. I would inquire further about the configuration of the high-resolution console mode, since I also would enjoy such a high-resolution console mode, but perhaps another time?

There is another issue of great concern and that is the obvious aspersions cast upon your character by the installer when you told it in no uncertain terms that you were an expert and would decide for yourself what would or would not be partitioned. I think SUSE 11 is noted for that although I cannot be sure about that. It is a reprehensible practice that should be discontinued. I do not agree with the practice at all! And, I am unanimous about that!

It is with the greatest and most humble apologies that I wish to tell you the truth concerning this matter. The GRUB is a monstrous creature and hardly to be tamed by human hand. This beast is always eager to seize any opportunity to throw down mere mortals and it used your valiant attempt to install SUSE 11 as an occasion to do that very dastardly deed.

Obviously, although GRUB is sworn to obey the rules of the game, it decided not to display to you the SUSE 10.1 installation already residing on your pristine computer, nor did the beast indicate in a message to you its intention regarding the placement of its beastly residue within the MBR or another partition. This is a serious breach of installation protocol and GRUB is notorious for such primitive actions.

That, in a nutshell (I apologize for the brevity) was and is the difficulty.

Again, may I offer my apologies and condolences for the despicable behavior of the SUSE 11 installer and also, rest assured that you have my sympathy but also my admiration for surviving a battle with the beast GRUB.

If I might assist in another manner or with further information, I am your servant.

If you can get the LiveCD to boot (not hard drive), get it running and look at your partition table in the Yast partitioner and see what you have. You could also try looking at the bootloader but I think it will simply report for the Live CD.

Report back on the partition table - what is in there? What hardware are you using?

Also, you might find it helpful to download a copy PartedMagic 3.0 and burn a cd. http://

You would do well also to read up a bit on GRUB.http://

You haven’t mentioned Windows being in there, or if you have lost data or whatever. Actually, you said very little. If there is absolutely no question of losing data or losing a windows install, simply reinstall and pay particular attention to the partition recommends and the notice given about what GRUB intends to install and where to.

Otherwise, read the partition data and report back here with a guess as to where you thought 11 went.

If you scout through Herman’s GRUB page, you will see a section on how to edit GRUB from an editor, before boot. You can discover partition tables, etc. within GRUB command line. Edit GRUB and reinstall GRUB correctly.

Or, you can simply reinstall. However, if you don;t know what happened the first go round, you aren’t likely to get it right this time.

Don’t give up. It is just that many times there is a bunch of tedious crap to be attended to. I just tried to use my 11 Live CD to take a peek and the stinking thing wouldn’t boot. So, I use a Fedora 8 Livecd which is very quick.

If you haven’t understood anything about what I said, simply reply. Someone will jump in hopefully. But, the link to the GRUB data is very good and quite easy to follow.

It doesn’t matter what is on your drive, windows or whatever, we need to know where you put 11.