grub error 17 while windows install normally

recently after a reboot i got grub error 17. no updates, no nothing - just an innocent reboot. i tried literally everything(supergrubdisk, grub commands, menu.lst editing etc.) to get it to work but nothing helps. even reinstalling different linux distros gives the same grub error 17 while reinstalling windows it boots properly.
and this is not a dual boot issue.
i’m just going mad. why windows boots but none of linux distros does?
could it be related to a broken hdd(bad sectors or something)?

If you have a Linux Live CD, boot from it and log in. Then open a console window and enter su and you will be at the command prompt with root powers and ready to proceed. If on the other hand you have the openSUSE install DVD, boot from it and on the first menu of options select the Rescue System option. That will start an elementary Linux Live operating system and bring you to the login prompt. Enter the username root and you will be at the command prompt with root powers and ready to proceed. Whichever way you started (the openSUSE install DVD or a Linux Live CD) when you are at the root command prompt, first you find the partition containing openSUSE’s bootloader. Then you reinstall Grub with a pointer to that partition. First find the openSUSE installation:

You enter this ---------------- grub
Computer returns like this ---- grub>
You enter this ---------------- find /boot/grub/menu.lst
Computer returns like this ---- (hd0,5)

Here, (hd0,5) is Grub’s pointer to my openSUSE installation. Your pointer will be different from my example (hd0,5). Substitute your values for my example (hd0,5). Now that you have the pointer, proceed like this:

You enter this ---------------- root (hd0,5)
Computer returns like this ---- Filesystem type is ext2fs, partition type 0x83
You enter this ---------------- setup (hd0)
You see several lines like this — Checking if /boot/grub/stage1 exists … yes Computer finally returns this-- Succeeded…Done
You enter this ---------------- quit
You enter this ---------------- reboot <code>
The computer should reboot and present you with the Grub boot menu

from here:

already tried that. same error 17

From Grub manual:
This error is returned if the partition requested exists, but the filesystem type cannot be recognized by GRUB.

Are you able to get the

fdisk -l

we asked for!

yes i am able to get it and everything is set correctly.
as i mentioned i tried different distros and different versions after i first got this error but all of them doesn’t load grub.
though i can install and load windows.
i have installed different linux distros on that particular laptop earlier and never got this error. so maby it is due to hard disk failure? i now recall that latest ubuntu alpha showed some notification about bad hard disk or something.

Post it. How can we help you!?

cannot post it now since i’m not at that computer currently.
maybe you’ve got some clues about why none of linx distros boot while windows doesn’t have any problems?

Yes, I have an idea you borked something.
A live cd will tell you all you need to know if you know what to do.

i managed to get the laptop so here what fdisk -l shows

Disk /dev/sda: 100.0 GB, 100030242816 bytes
255 heads, 63 sectors/track, 12161 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x8793a636

Device Boot Start End Blocks Id System
/dev/sda1 * 1 262 2104483+ 82 Linux swap / Solaris
/dev/sda2 263 1698 11534670 83 Linux
/dev/sda3 1699 12161 84044047+ 83 Linux

boot is at sda1 now cause i’ve been messing around with supergrubdisk and probaly left it like that

Really, I am having trouble making much sense of all this.

What is all this about windows.

Put the boot flag on sda2, make sure sda1 is a valid swap as your comments suggest you messed it up. Reinstall grub to the MBR. Use Parted magic to do all this.

the only thing it’s got to do with windows is that windows installs and boots without any problems while linux somehow started to show grub error 17 after any distro install.

i also tried
grub-install --root-directory=/media/root /dev/sda
in return i have
/dev/sda does not have any corresponding BIOS drive

so does it mean that bios can’t see the partitions?

Feel like starting again?
Wipe the disk with Parted Magic, format the entire drive to ext3.

Throw the suse dvd in and boot from it, let it run the install, just accept it’s defaults.

tried to restore it back and set to mbr
ive got
error 6: mismatched or corrupt version of stage 1/stage2
and error 18: selected cylinder exceeds maximum supported by BIOS.

ok ill try to wipe it with parted magic un then install suse again.

Your HD is it something you added?

no. it’s the original one. i’ve installed linux on it loads of times and did not have this error until recently rebooting.

now i get grub error 18

Give us a

fdisk -l


Did you ever tell us what your system is? Box? Laptop?

You are trying to install openSUSE 11.1 - correct?

no more playing with grub errors. i had to get the laptop working for tomorrow so i chose to install win xp which just worked. sorry for inconvenience.
since i googled a bit more i strongly suspect these errors have got to do something with write protected sectors made by manufacturer. so something must have gone wrong there but i really don’t know how to get to these sectors. though i did see them in one of partedmagic tools but erasing all hdd didn’t work for them.
the machine is a laptop. fujitsu amilo l1310g.
in my last attempt to install linux i even made a boot partition at the beginning of hdd but as i already mentioned i got grub error 18 again.