Grub doesn't start


I have recently ran an update on my system, running OpenSuse 13.1 x64. I hadn’t updated in a while and I had around 290 updates to do. After updating and restarting the computer, I was faced with an unresponsive Grub.
I have windows encrypted with TrueCrypt and Grub is chained from the TrueCrypt boot loader. This setup has always worked. And I don’t think that’s the reason beyond the issue.
TrueCrypt finds the boot partition and right after that Grub gets stuck. I have attached an image that shows when it gets stuck, it’s really early on and though it isn’t visible on the image, there are lots of “underscores” flying around in the screen.

I have no clue how to fix this!

Hi !

The .jpg that you linked doesn’t say that much.

That you use TrueCrypt (I don’t know it) makes things a bit complicated.
The ones participating in this forum usually are focussing on openSUSE distributions.

Although I don’t know nothing about TrueCrypt, and although I still use 12.3 (instead of 13.1)
I have an idea, not more:

there have been several updates of the Kernel recently.

Every Kernel update enlarged the list of the bootable systems of my GRUB menu
(I’m still using legacy GRUB).

Can ‘TrueCrypt’ handle such changes of the GRUB menu ??

Maybe your openSUSE/Linux on your hard disk is OK (after the updates).

Maybe you could fix your problem by booting from a live openSUSE,
and re-configuring the GRUB boot loader on your hard disk.

Since you can’t boot your openSUSE from your hard disk,
booting from an openSUSE live medium and probably ‘chroot’
could pave the way. Possibly.

Good luck anyway !

Thanks for your quick reply :slight_smile:

I am not sure what grub version I am using, but I know it is the default one.
I only have OpenSuse’s DVD, and not the live session CD. So I can only boot into the recovery environment, no graphic environment, just a console. So basically what I need to know now is what are the command to re-configure grub. I am guessing something to do with yast? grub-mkconfig doesn’t seem to be it, and it’s the only one I know off!

Ok I found something!

A bit about my partition scheme:

  • sda4 - extended. Partition where the others are “encapsulated”
  • sda5 - swap
  • sda6 - this is the root partition
  • sda7 - partition for home folder

I have tried to reinstall grub2 by using

#grub2-install /dev/sda6
mkdir cannot create directory ?/boot/grub2/i386-pc?: read only file system

sda6 is the place where grub2 was previously installed, and still is.
Since I am using the recovery environment from the CD I guess that’s the reason for the mkdir warning - I am also using a 64 bit version of OpenSuse and a 64bit installation CD

I also tried:

#grub2-mkconfig -o /mnt/sda6/boot/grub2/grub.cfg
/usr/sbin/grub2-probe: error: cannot find a device for / (is /dev mounted?).

No idea about the why of the error. Maybe related with the same problem I was getting above.

Please show output of “cat /etc/default/grub_installdevice” from your root partition.

Check out

Did you chroot before you ran those commands?

That was it, I didn’t use chroot. I am a novice at this, and didn’t completely know how to proceed.
Thanks for all the help :wink: Everything is back to work now.

Any ideas on what caused grub to die like this?

Hard to tell
Did the update seem to go smoothly?

That’s hard to say, since there were so many updates, I wasn’t paying much attention to what was going on. I update by using the command “zypper update”
There were some information about app armor I think.
I am just wondering if something got corrupted besides grub and needs fixing?

If it’s running OK and booting OK you should be good now

Good to hear that.

I don’t see a reason for that.

From your first posting:

At least for non-UEFI-booting systems the situation usually is vice versa:
the windows boot loader usually is chain-loaded by the Linux boot loader (Grub).

So I guess that your configuration with Grub being chained from TrueCrypt caused the problem that you had,
while the updates obviously installed OK and your system is running fine now !

This, however, may mean that your Grub could be broken again, if there’s another Kernel update.
Be prepared :wink:
Probably you don’t want to give up using TrueCrypt …

Good luck

Thanks for all the help :slight_smile:

I don’t know if TrueCrypt is the one to blame here. I have used TrueCrypt with fedora, before I moved to OpenSUSE, and fedora has lots of kernel updates.TrueCrypt just searchs for other bootable devices (or partitions) and presents them as options for alternative booting. If I had a USB thumb drive pugged in it would be displayed has an option.
I am thinking that something went less fine with the update, maybe a consequence of the way I have grub stetted up - not in the MBR.
In any case I am glad it’s all fixed. :slight_smile:

Fedora may do whatever it likes (I’m not familiar with that) - openSUSE has always taken control and chain loaded other OSs.

Look, when there are kernel updates, openSUSE tries to modify the boot loader (GRUB and/or GRUB2).
But then TrueCrypt can’t care anymore, because it isn’t active anymore - it is not an operating system after all !!

Forget it.

Or do explain to me now, why your system now runs smoothly ???

Good luck