Grub doesn't like me

Hello again, I’ve already posted, but haven’t gotten any responses yet. Hopefully someone can help me.

I’m trying to install 10.3 on a 4th sata disk. Disk 0 and 1 are a RAID0 array (with XP), disk 2 is a backup disk (NTFS) and my latest disk is dedicated to SuSE. (with a very small slice to play with the new OpenSolaris – 25 gig partition). Solaris installed well (I think because it didn’t recognize my raid configuration). I have set up disk 3 as disk 1 in the boot order in the bios. I install Suse, and get all the way to the boot loader configuration during installation, and get the “Error 23 – Error while parsing number”, pointing to “grub>setup—stage 2 = /boot/grub/stage2 (hd0) (/dev/sdb 2,1)”

I have tried every conceivable change possible in the configuration, including write boot loader to the MBR, write to boot partition (which I would prefer to do) write to swap, etc. but no luck. I have overridden this in the past by not installing the bootloader, and later fixing it with supergrub, but this is not the most desirable workaround. I have a feeling that the problem must be the (hd0) as the physical location of my HD is not 0, (but it is in the boot order), but cant change it. Any suggestions?

Much thanks from Brazil!

Can you boot into Suse from the install DVD?

It’s a disk map thing.

If you truly have it setup in bios as disk1 and with Solaris on the 1st partition, then /dev/sdb 2,1 is wrong & should be /dev/sdb0,1 Grub counts from zero.

Have you installed & trying 1st boot?

Hi guys, thanks for the response. No Swerdna, I cannot boot from the install CD. Not even with supergrub. I have since wiped my install hd, and reinstalled SuSE using the entire disk, but I get the same error. I have tried to install SuSE 11, but get an error at the same place (boot loader configuration during installation) except with “Partition not found”. The only thing I can think of is that it is finding the physical HD0, which is the first hd of my raid array. I know you guys would need more information to help me, I just can’t get to any additional info. If you can give me any suggestion based on this little info I have offered, I’d be grateful.

Thanks again,


Why don’t you try pulling the cables on the raid disks, get the install up then you can add back the raid disks and modify your menu.lst.

BTW, what does Parted Magic LiveCD show as far as the disk order goes? What ever that is that should be what your disk map in Grub reflects and thus your (root x,y) entries. (When you go changing the boot order in bios, it screws up the disk map in the OS & you have to take that into account)

Thanks Snake, good idea. I’ll give it a try and let you know.

best regards,