GRUB - can't load up Ubuntu after installing Opensuse 11.3

Hi All,

First of all, I’m a first time Opensuse user and loving it!

Now I installed Opensuse on my system which already had Ubuntu 10.04 and Windows 7 on it. Whilst Opensuse’s replacement Grub correctly identified Windows as an alternative system it did not do the same for Ubuntu. I’ve been tinkering around in menu.lst (after taking back ups) and I can’t ever get Ubuntu running - I either get a Grub error 15 (file not found) or error 17 (unable to read partition).

By booting on a live CD I can see that all the information is still there, I just can’t for the life of me figure out how to get to it from Grub! Did Opensuse move the partitions around during install?


Have a look at this thread:
How to boot back into Ubuntu after OpenSUSE 11.0 install
Adapt the hd(0,0) to your grub partition.
Ubuntu stores its grub menu.lst in the file /boot/grub/grub.cfg

This thread might also help you :

Unable to boot kubuntu from 11. grub

HowTo Multiboot Ubuntu from openSUSE using the GRUB bootloader

or use grub 2 by re-installing like this

Thanks guys I’ve fixed this now.

Boy do I feel coy now. I’d looked at those threads before and had tried them both in the knowledge that my Ubuntu partition was SDA7 and therefore (hd0,6). This didn’t work. So this time I just did trial and error heading back down SDA6 and then onto SDA5 where I struck gold! Seemed odd at first until I realised what the initial problem must have been - when installing Ubuntu I had set up a separate /boot/ partition at the start of my extended partition (SDA5 or hd0,4) and this was why I hadn’t got it working at first! Embarassing I know. Now it works fine.

The only niggle (which I’m going to scout for threads for and fix tonight) is that once in Ubuntu and installing updates my GRUB2 updated moving me back onto this version. Not an issue, but I’ve lost the OpenSuSe boot splash!

Thanks once again!

P.S. How do I mark this thread as solved?

This I would say is fine, you having grub2 in control.
Forget the splash it matters not.

Just FYI, when ever there is a kernel update in suse, you need to do this in Ub*

sudo update-grub

*No facility here to mark as solved