Grub can't install

Dear All,

I have downloaded OpenSuSe 11.2 this night and tried to install it on my laptop, which I presume all hardware supported (it is in Fedora, should be in OpenSuSE).

There is a installation of Windows 7, which was made with the retail disk from Microsoft, including partitioning.
When I tried to install Fedora, it sees my disk as free space and no partitions. Thats why I returned to check OpenSuSE (I’ve used SuSE from 5.3 to 7.0) and have good memories from those days (remember the old Voodoo Banshee, Intel i740 support days? SuSE owned those days).

The SuSE installer reports that my disk is partitioned using a GUID and doesn’t allow me to change partitions, though fdisk on command line allowed me to create the following:

1 4GB swap paritition (0x82)
1 50GB ext4 paritition (0x83) (used as /).

The system installed fine and restarted for configuration, on the final step from the configuration it self-booted.

I then started with Rescue System and made the following:

dd if=/dev/sda4 of=/mnt/win7/boot.lin bs=512 count=1

And configured the Windows 7 boot loader to boot Linux.
Epic fail. It should work in theory.

Booted again with Rescue and mounted the Open Linux install, chrooted the system and checked for Grub Config files (/etc/grub.conf; /boot/grub/ files).

Everything seems to be ok, the hassle is that when I run grub-install it reports me with an error:

Error 21: Disk is not present

Or something like this. Well the disk is actually present and mounted, it’s recognized. I am not sure if this has something to do with Windows 7 partition system. I honestly don’t know the Windows 7 boot method, but it seems it creates an extra partition for the boot (maybe EFI ?).

Anyone has run acrossed this ? The truth is that I am a Marketing Manager and unfortunatly I relly on proprietary software for windows to perform my job, and this is not the right time to re-partition my whole hard-drive as I am doing something important and dont have my SPSS/Sphinx licences at hand so I can’t reinstall the whole thing again.

Any help on this matter would be greatly appreciated.

I’m currently installing OpenSuSE on one of my external drives, but I’m not much fond of running my OS from a external drive.


By the way a quick info, my Laptop is a Sony Vaio NW21EF/S, and the BIOS is locked. Though I’ve dumped the BIOS and enabled Intel VT support through editing and flashing again the BIOS, I don’t have access to most functions though the normal BIOS setup, including power management and such. Don’t send me to BIOS because there’s nothing I can do there besides managing my boot devices and CMOS time/date functions.

Re-Install Grub Quickly with Parted Magic - openSUSE Forums

Did you bothered reading what I said?

Grub reports error 21.

Chameleon boot loader works fine :slight_smile: Cheers for the OSX people!

So you’re getting to GRUB. Then in GRUB, there should be something wrong with the info it gets from the files. Error 21 means disk not found.

In the graphical GRUB menu, hit Escape to go to text mode. This way you can edit the bootlines. You will see things like “root (hd 1,0)” meaning disk 2, partition 1. Check these out against what you know, or play around with them.
The disk can not be mounted, linux does that during boot. Error 21 means it doesn’t.

If you find out how the drives are mapped, you can adjust the line in GRUB, boot, and then change /boot/grub/menu.lst accordingly.

I tend to say GRUB boots any linux system these days. Other supported OS’s can be made to boot from there.

Hope you have not yet made your system a very custom situation, you may run into that later.

I would suppose that grub can’t really read the partition tables if they are GUID partitioned.
Honestly I stopped caring about it and tried to install openSuSE on an external USB hard drive. It goes fine, but it only allows me to use the MBR of my internal drive not the MBR of my USB drive. So eventually it installed with Grub on the partition. Then I pulled out one of my hacked snow leopard disks and dumped Chameleon as boot loader. Works like a charm now.

Grub still gets more pathetic because depending on the boot stage it has different ID’s for the external drive. It’s too much of a trouble just because of a boot loader. I have a fully running system now with all hardware properly configured, and for boot. Chameleon does the trick… and it open fun new doors, so my next step is checking EFI developments on linux and start doing some other hacks around, specially on my ATOM BIOS :slight_smile: