grub can't boot into Suse after adding a hard drive

Hi everyone! I have Suse 11.2, Ubuntu 9.10 and 7 tripled boot on sda.

With the generous help from caf4926 and please_try_again, i was able to boot into Ubuntu 9.10 with suse’s grub legacy.

Now I have another problem that i’d need help on, I added a new IDE hard drive for storage and it became sda and the original sda with 3 OSes changed to sdb. Grub can’t boot into any OSes except windows 7. Well, i can still boot into Ubuntu if i change the boot option from

root=/dev/sda2 ro quiet splash

to

root=/dev/sdb2 ro quiet splash

For the past few days, I’ve tried to tackle the problem with Grub super disk, boot from Ubuntu/Suse livecd to reinstall Grub to the MBR on hd1, reconfigure Suse’s grub from its Yast bootloader but they were fruitless.

my partition table

Disk /dev/sda: 200.0 GB, 200049647616 bytes
255 heads, 63 sectors/track, 24321 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x0000f191

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1               1       24321   195358401    7  HPFS/NTFS

Disk /dev/sdb: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x0af20af2

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1               1        2550    20482843+   7  HPFS/NTFS
/dev/sdb2            2551        5100    20482875   83  Linux
/dev/sdb3   *        5101        7650    20482875   83  Linux
/dev/sdb4            7651       19457    94839727+   5  Extended
/dev/sdb5            8161       19457    90743121    7  HPFS/NTFS
/dev/sdb6            7651        8160     4096512   82  Linux swap / Solaris

I appreciate your time and help!

You need to switch the boot order of the new HD so it’s the 2nd HD in the boot order and if necessary move the jumper on it to make it slave too

The easy fix would be to change the plugs on the motherboard so that the disks are in the right order. This would put everything back the way it was before you added the new drive.

hi guys, thanks for the quick replies

I should have put this in the first post. The hard drive with 3 OSes installed on is a SATA drive.

Anyway, my IDE hard drive has the jumper set to slave. I also checked the BIOS.

The “Boot Device Priority” is as folow
1st CD-Rom group
2nd Hard drive group
3rd Network boot group
4th Floppy

In the “Hard drive group”, it’s already correctly set

1st hard-drive → Samsung (the SATA drive with 3 OSes)
2nd hard-drive → Western Digital (the newly added IDE drive)

It appears your BIOS is giving priority to IDE ports. Go through it and see if there is a setting somewhere to change its priority to SATA.

I went to BIOS, i notice the

“On board PATA/SATA Adapters” set to [Both]

if i change that into [SATA] only,then it fixes the problem but that because the BIOS disables the PATA of my IDE Western Digital Drive. That’s equivalent to physically unplug the cable to the IDE hard drive

Then you are limited to reconfiguring all the settings that point to the old drive.

It may end up being easier to reinstall.

You could always put the IDE drive in an external case. It would be slower that way though.

I solved it man rotfl!! The solution was in my BIOS setting too.

In the “advanced” tab, i changed the “Onboard PATA/SATA Configuration” from “Enhanced Mode” to “Combined Mode”. I don’t really know what it means but it puts thing back to normal. My 3 OSes drive is now changed back to sda and the IDE drive now becomes sdb

Disk /dev/sda: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x0af20af2

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1               1        2550    20482843+   7  HPFS/NTFS
/dev/sda2            2551        5100    20482875   83  Linux
/dev/sda3   *        5101        7650    20482875   83  Linux
/dev/sda4            7651       19457    94839727+   5  Extended
/dev/sda5            8161       19457    90743121    7  HPFS/NTFS
/dev/sda6            7651        8160     4096512   82  Linux swap / Solaris

Partition table entries are not in disk order

Disk /dev/sdb: 200.0 GB, 200049647616 bytes
255 heads, 63 sectors/track, 24321 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x0000f191

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1               1       24321   195358401    7  HPFS/NTFS

Thank you for pointin’ me to the right direction. Appreciated! lol!

You’re very welcome! Glad to be able to help.:slight_smile:

Thank you for pointin’ me to the right direction. Appreciated! lol!

We knew it that BIOS settings - well done;)