Grub cannot install

Hi there, got Suse 11 working great on my laptop at home (apart from minor issue after upgrading kde I think!!).

Thought I would install on my PC at work, for some reason though it comes across a problem…

On install it goes through and repartitions my Windows (Vista Ult x64) drive and creates its partitions, then formats and copies a load of files. Then it tries to install Grub and fails with “Error 22”. I can’t remember the exact wording now. Tried Lilo and same result (different wording etc but same gist). I even tried removing all of the windows entries it was trying to create but still the same…

Can anyone help me?

First, please verify that everything is still alright with your Vista partition(s). Second, whenever partitions are going to be changed (such as re-sizing), it is extremely important to have a backup.

There are several possible causes for grub error #22, usually either the installation is being pointed to the wrong partition or the root reference in menu.lst is invalid. Especially since you have Vista, the first step is to know the disk/partition layout. Boot from a live-CD and open a terminal, or boot from the DVD into Rescue Mode, and from the prompt do:

fdisk -l

And post the output back here. Also, we need to know, do you want Vista or openSUSE/grub to control booting on the machine?

Once we have that information, we can determine how grub will need to be installed. At that point, when you re-run the installation, you will be going into “expert mode” at the Boot Manager step, and instructing it exactly where/how to be installed.

Thanks for your help. Sorry for not coming back sooner but I have been busy at work!

I managed to fix it by doing a “Repair Installed System” from the Install DVD. It managed to write a bootloader, once I excluded the Windows partition.

Once I had SuSE up and running I then just put a manual entry for the Windows partition and all was well.

Terrific! Now . . . enjoy, and welcome!