GRUB bootloader corrupted (dual XP and LINUX)

Hi all,

something quite incredible happened…and i see no way out…

I have 1 HDD in my system. The first two partitions are NTFS, the first has XP installed.
After having XP installed, i installed opensuse 11.1, with the GRUB bootloader, which also had the XP as menuitem. I just used everything, as it was offered, with default settings.
(So the Linux partitions are after the NTFS partitions.)

This worked fine until today, when I unfortunately happend to try to change the order of the items in the GRUB menu (after normally logging to linux, kde, yast2 , boot loader)
I just change the order, and the waiting time for the default menu item. Changes were saved, and …
Since this time the system doesn’t start, no error message, just blinking cursor instead of GRUB.
I tried to use the install CD, to

  • use the automatic repair … it says that the boad loader has errors, repairs it with the a default new config, but nothing changes.
  • use the expert tools to fix the boad loader … systems it doesn’t even find linux partitions, or says errors on the ext partiotions. … piece of crap

I even tried to use the XP install cd in recovery mode,
and use bootcfg /rebuild, fixboot, fixmbr commands … no change, the same blinking …

What the hell happened ??
How can I fix this piece of crap ?

Thanks, sorry i am nervous

Not too hard. First boot into openSUSE. Then use Yast’s bootloader module to regenerate the Grub bootloader and reattach it to the booting code in the disk’s Master Boot Record.

This tute will show you five different ways to boot into openSUSE:
HowTo Boot into openSUSE when it won’t Boot from the Grub Code on the Hard Drive

If you have the Suse installation DVD use method #1 to boot Suse – followed by the method in the Appendix to re-do the Grub menu.

If you don’t have the install DVD I’d try method #3 with the openSUSE Live CD to get the existing bootloader reattached to the Master Boot record and see what happens when you reboot.