GRUB/ Boot problems

Hey guys, I just dual booted my machine last night with OpenSUSE 11.1 KDE. It installed properly and everything was fine until I did one thing. I am new to the Linux environment so I don’t know much about it. Heres what I did that I think screwed it up. I went into YasT and went to the bootloader options. I wanted to change it so that Vista would be the default boot, so I saw an option to make it “default” and hit OK. After that I rebooted and all hell broke loose, I couldn’t boot into anything…meaning I think I screwed up the GRUB. I can boot from the Live CD but not HD and I don’t know if I can fix anything from that. I tried “boot form hard drive” option from Live CD welcome screen but nothing happened. Anyone who has an idea please try and help and I’ll get back to you as soon as possible.


Did you have a look at this thread already.

11.1 / XP boot loader major problem - openSUSE Forums

Looks like this might cover your problem.

Ok I went to the link you supplied and I also visted GRUB Boot Multiboot openSUSE Windows (2000, XP, Vista) using the Grub bootloader and I got to this part: "On the boot screen choose to “Repair Installed System.” but there was no option to repair the installed system from the CD I have, is it on the DVD only?

Well, I do not know about a 11.1 OpenSuse distribution on CD. But, I also did not succeed whith the repair option, although I tried to :’(. I guess, that I did a big mess before. So, in your case, I would just install the system once again ;). (As you said, your system is pretty “unused”, so there is no data lost, when you just start from the scratch, right?)

So, you can start another installation, and when anything will - hopefully - be reproducible, you will end up with a running linux system. Take care at the installation process, when the configuration offers you the setup preferences. There a bootloader configuration is shown (first topic on top). Make sure that the MBR option is checked (should be, as your installation did succeed last time).

Now, when you start to bimp your bootloader configuration using YAST under your - once again - pretty nice and clean installed system, MAKE SURE, MBR is CHECKED!!

For some reason, YAST forgot to check this.

BTW. Two other traps, I found:

in /boot/grub/menu.lst the wrong disk was selected:

  1. the linux partition was /dev/sda6. However, grub said hda(0,7), which is my /home partition.
  2. the root=/dev/disk/by-uuid entry was wrong, I changed it to root=/dev/sda6

You better carefully check these parameters in YAST as well.

Good success!

Actually no lol I do have some things to worry about if I reinstall the whole system. I dual booted Vista and OpenSUSE and I have stuff I need on Vista that I can’t access. I havent tried seeing if the option was on the DVD as I am downloading it now but I’ll post back soon and tell you all my results. I think after I get this all up and running again I might just end up uninstalling SUSE so I don’t have to worry about this torture again, so if theres a way to uninstall SUSE and the bootloader without having to worry about “muckin” up Vista or anything bootwise that would be great if anyone could link it.

Thanks again,

Sorry, I did not want to bother you with reinstallation of vista. I mean, reinstall just opensuse, as you did it before. This step was not destructive to vista, so you do not need to reinstall vista. I am sure, you could reproduce the installation process as you sucessfully described.

To uninstall linux, you may just start your Vista DVD into the administration prompt. fixmbr and fixboot should give you back your regular vista booter. format your linux partitions and all is over…

However, as this is Windows, be careful!