Grub boot problem after last kernel update

Hi all,

on yesterday I run zypper update and I updated kernel to

Then I updated as usual ubuntu grub menu list (because I have both installed and I use grub from ubuntu)

But when I start opensuse, it seems to boot but after about 10/20 seconds it shows the message that it can’t find the root partition

I tried also to change from /dev/disk/by-id/ata-Maxtor_6Y120L0_Y341RTSE-part6 to /dev/sdb6 but it cannot find /dev/sdb6 as the first one
/dev/sdb6 is perfectly readable from ubuntu, so it is not corrupted.
These are the grub lines for opensuse

This entry automatically added by the Debian installer for an existing

linux installation on /dev/sda10.

title openSUSE 11.1 - (default) (on /dev/sdb6)
root (hd1,5)
kernel /boot/vmlinuz- root=/dev/disk/by-id/ata-Maxtor_6Y120L0_Y341RTSE-part6 resume=/dev/disk/by-id/ata-Maxtor_6Y120L0_Y341RTSE-part5 splash=silent showopts vga=0x31a
initrd /boot/initrd-

What could be the problem? :’(

The problem initially was that the kernel that the Ubu loader points to is no longer there because it was updated. Try this one instead, from this tutorial on just that problem:
HowTo Multiboot openSUSE from Ubuntu using the GRUB bootloader

# Swerdna's entry to boot the openSUSE installation on /dev/sdb6 by symlinks
title openSUSE 11.1 (on /dev/sdb6) by symlinks
root (hd1,5)
kernel /boot/vmlinuz root=/dev/sdb6
initrd /boot/initrd

At least, it seems to be that problem since it happened right after your openSUSE kernel update – the fix worked for me in the same situation.

PS if that works you could try modifying the vmlinuz line to get the silent boot and vga res back, to this:

kernel /boot/vmlinuz root=/dev/sdb6 resume=/dev/sdb5 splash=silent showopts vga=0x31a

This was what I suspected on yesterday but I updated the grub configuration with the right kernel

from /boot/vmlinuz-

to /boot/vmlinuz-

but it didn’t solve the problem

I will try with your suggestion… I keep you updated
By the way, I see that /boot/vmlinux is pointing to vmlinuz-

/boot/vmlinuz -> vmlinuz-

thanks a lot



I modified grub as suggested but the problem is not solved.
The message error is the same, it can’t find /dev/sdb6…


It’s possible that the online update on openSUSE was not completed. Perhaps you could boot into openSUSE and check in Yast’s online update module if there is anything more to install in terms of updates. The openSUSE install dvd has a facility for booting the existing suse installation.

It’s outlined here: HowTo Boot into openSUSE when it won’t Boot from the Grub Code on the Hard Drive


I will try and update you which solution works :slight_smile:

Thanks again

You might be in with a chance here. See post #3 in this thread I found by googling “vmlinuz trace”:
What is /boot/vmlinuz- - No GUI - openSUSE Forums