grub boot menu

i deleted all my linux opensuse files in my c:/
now i cant access my windows xp it brings me to the grub terminal

You need to repair your MBR with a XP Disk (fixmbr)

Windows 2000/XP on the computer: Boot from the XP/2000 installation disk and proceed to the final screen where you have the option to Repair Your Computer. Press “R” for Repair and log onto the Windows installation. When the command prompt appears, enter the command fixmbr. Confirm “yes” and you will receive confirmation of the reinstallation of Windows bootstrap code into the MBR. Enter exit and the computer will reboot.

copy d:\i386
tldr c:\
 copy d:\i386 c:\

You might find this useful
Super Grub Disk Homepage - Download CDROM

is there no other way? :X

You have to repair your PC’s MBR (master boot record). It is currently setup to go your partition that you deleted and load the remaining grub stage(s) and also menu.lst, neither of which exist.

Its possible you “might” just be able to make /dev/sda1 active and that will be enough, but I doubt it. More likely you need to follow caf4926’s advice.

If your PC has a floppy drive, you may be able to boot from a Windoze boot floppy and restore your MBR with “fixmbr” dos command. Or if your PC has a CD drive, you may be able to boot to you MS-Windows Rescue CD (if you have one) and restore the MBR that way, … or try supergrub disk that caf4926 suggested.

To get other ideas, do a google search for “restore windows mbr”

As @oldcpu intimated. It might be that if you make active the windows partition the pc will boot. It depends if grub was written to the MBR when SUSE was originally installed. Get hold of Parted Magic: Downloads - Parted Magic

The Partitioner in there will allow you to set the Boot flag to the windows NTFS partition.
But when you boot if it responds with something like ntldr missing. You need to fix MBR.
As has been said there more guides on that than I’ve had hot dinners.

Slacker – you don’t have time for that!

And food just became a deal less interesting for me with my new ‘Food Intolerance’ diet. No Dairy, Gluten, Yeast, Eggs, :frowning: