GRUB and bootsplash on EEEPC

Hi,

I have 2 simple questions regarding booting process.
1-How can I dissble GRUB menu on boot. I only have 1 system on my eeepc, and I want it to boot directly.
2-For some reason I don’t get a nice splash picture that usually masks SuSE boot proceess. It’s just black console screen up untill X. How can I configure it? (resolution on eeepc is nonstandard 800x480,which I think might be a reson)

you can select in the system settings → Grub Editor → options → hide boot menu and set the boot default entry to 0 sec

doesn’t have the EEE PC the resolution of 1024x600?
mine 1000H has it

Thank for your answer. My eeepc is really old. so 800x640 max. But in genral, how do I set the bootsplash (I think that’s what it’s called) on Suse?

The bootsplash theme does not contain an image sized to your resolution, or a config file for it. Once that is done, you may need to re-create the initrd specifying the resolution. Here’s a thread with the link at bottom to a guide . . . (btw, searching on “bootsplash” turns this up) . . .

Bootsplash not working… can anybody help? - openSUSE Forums

Thanks for all the replies, but nothing I do seems to work

If any of you out there know how to enable bootsplash for SuSE 11 on older EEEpc with 800x480 res, please let me know.

nothing I do seems to work

doesn’t tell us much. In the openSUSE theme folder did you:

  1. Create a 800x480 jpg?
  2. Create a 800x480 config file, modified for this resolution?
  3. Run mkinitrd with the resolution parameter?

All 3 steps must be done correctly to add your resolution to the theme.

Yes, I did all that. the problem is that I can’t seem to find the right vga code for grub to set. no mtter which I set it’s always wrong. I tried to google, and found 800x480 code, but grub returns error saying that it’s not supported. I tried to list the frame buffer modes, and it tells me I have 640x480 mode, so I set it up but once again got a black console.
I know that original Xandros, and Ubuntu eeepc edition got itt working somehow, but not suse :frowning:

They may be using a different software mechanism. Perhaps googling it for Ubuntu may turn up what that something else is, and you could possibly use that in openSUSE. Just a thought.

Oh this is jusr great! I broke the suspend :’(
It uset to work fine every time I would close the lead, and now it doesn’t!