grub acting wierd


I installed Opensuse with Grub on the extented partition.
But if I start my computer Grub is seen.

And also when I go to yast > System > Bootloader I cannot change Grub because the boot choices are not visible.

How can I change that Grub can be changed and I can use my old bootloader (Easybcd)


It’s not that I would have a solution, but there are at least 2 points that you should give more info on or think about:

(1) which version of openSUSE did you try to install ?

(2) AFAIK Easybcd bootloader isn’t included in openSUSE.
So to get that running again you will need different software, don’t you ?

yes. you are correct.Easybcd is a piece of software to edit the Windows 7 bootloader.
Easybcd is now complaining that it cannot find the windows bootloader.


Edit 1: I still find it wierd that I see the grub bootloader on booting up the computer where Grub is installed on the extented partition.

I suggest you over wrote the MBR with the openSUSE version of the generic MBR code. That may confuse EasyBCD

you will need to restore default Windows MBR with directions provided here:

i dont know about this software but from easybcd wiki it appears you can boot linux by chainloading with grub:


EasyBCD can boot into Linux by one of two means:

Chainloading GRUB/GRUB2/LILO/etc.

The traditional chainloading method creates an image of the GRUB/LILO bootsector on the local disk and loads this image during boot-time in order to chainload the second bootloader which should already be configured to boot into Linux or BSD. EasyBCD has profiles for and officially supports the chainloading of GRUB (Legacy), GRUB2, LILO, eLILO, and Wubi (for Ubuntu).

EasyBCD also ships with NeoGrub, a customized build of Grub for Dos, which can be configured by editing C:\NST\menu.lst with the standard Legacy GRUB syntax for directly booting into the needed Linux or BSD partitions, or chainloading another bootloader to load the OS in question.

I think the same.

This isn’t weird in the end. Windows by itself will do all but boot any Linux. So to be able at all to boot an installed Linux (like openSUSE),
a new boot loader (e.g. GRUB/GRUB 2) has to be put in place in a way that it takes control first. In general that will be the only way
any multiboot with Windows can work reasonably.

But can you boot Windows and openSUSE now?
That would be what you wanted to (or at least what you ‘ordered’ by installing openSUSE the usual way).

As far as I can see, EasyBCD should in the end be able to boot openSUSE, but that would be a very special setup for which you hardly will find support here.

As I saw further, EasyBCD should be able to restore a previously saved MBR.
Did you make any backup in that respect?

And please tell which version of openSUSE you installed.

I too use EasyBCD, because I prefer to have the Windows bootloader in charge (installed onto the MBR).
I suspect that this software is not updated to the latest version of Grub :expressionless: .
I usually solve the problem this way lol!:

  1. install Grub in the /boot partition; by default it install in the extended partition (don’t understand the reason why …) :;
  2. in EasyBCD, choose grub legacy (not Grub2) and (obviously) point it to the Linux /boot partition in which Grub2 is placed (the same I do with the Fedora Grub2 bootloader).
    In the openSUSE bootloader option is better non to set the active flag to the /boot partition, otherwise it’s impossible to launch the Windows bootloader at start-up.
    Let us know if it works …


I did repair the windows mbr by using the windows cd.
Before that I did install grub into / . I have only / swap and home.
After that I told Easybcd that grun can be found there.

But the only thing I see is a blinking cursor.
I also tried to re-install Opensuse 11.2 (64-bit) and tell the installer to install grub on /dev/sda6 but then I see a message that grub is not installed into the first 128 G of the disk.
That is correct because the first 200G are Windows and the last 100G is Opensuse.


After reinstalling Linux, you have to repeat the EasyBCD procedure …
Are you sure you pointed the EasyBCD loader to the right / partition? :\

yes. I’m sure.