GRUB 2 not showing up when dual booting + other OS not recognized

Recently I received an old laptop Sony Vaio VGN-C13G (originally it was released in 2006). Added more memory. Now it has 3GB. Than I decided to install 2 Linux distros: SUSE 13.1 and Mint MATE 17. And some problems started.
After any installation Grub 2 was not showing up. I followed many forum posts how to make it visible. I tried experimenting with different distributions: Ubuntu, CentOS, Mint.
To make sure that there were no leftovers I low formatted HD using

if=/dev/zero of=/dev/sda

Finally I created just 2 partitions. Installed Linux Mint on /dev/sda1 and Open SuSE on /dev/sda2.
Still Grub 2 was not showing. When I changed to Legacy Grub (using YAST) I can see its menu but without Linux Mint.
I tried also tried YAST>Boot Loader Settings>Other>Reread configuration from disk.

Please have a look at some more info which might be related to my problem:

linux-sony:/home/zbyszek # fdisk -l

Disk /dev/sda: 80.0 GB, 80026361856 bytes, 156301488 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk label type: dos
Disk identifier: 0x000ab6da

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1            2048    74399743    37198848   83  Linux
/dev/sda2   *    74399744   148766719    37183488   83  Linux
/dev/sda3       148766720   156301311     3767296    5  Extended
/dev/sda5       148768768   156301311     3766272   82  Linux swap / Solaris
linux-sony:/home/zbyszek # 

linux-sony:/home/zbyszek # cat /boot/grub/menu.lst
# Modified by YaST2. Last modification on Tue Aug 26 17:50:44 EST 2014
# THIS FILE WILL BE PARTIALLY OVERWRITTEN by perl-Bootloader
# For the new kernel it try to figure out old parameters. In case we are not able to recognize it (e.g. change of flavor or strange install order ) it it use as fallback installation parameters from /etc/sysconfig/bootloader

default 0
timeout 8
gfxmenu (hd0,1)/boot/message
##YaST - activate
##YaST - generic_mbr

###Don't change this comment - YaST2 identifier: Original name: linux###
title openSUSE 13.1
    root (hd0,1)
    kernel /boot/vmlinuz root=/dev/disk/by-id/ata-TOSHIBA_MK8032GSX_X6IJF5AHS-part2    resume=/dev/disk/by-id/ata-TOSHIBA_MK8032GSX_X6IJF5AHS-part5 splash=silent quiet showopts
    initrd /boot/initrd

###Don't change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe -- openSUSE 13.1
    root (hd0,1)
    kernel /boot/vmlinuz root=/dev/disk/by-id/ata-TOSHIBA_MK8032GSX_X6IJF5AHS-part2 showopts apm=off noresume edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 nomodeset  x11failsafe
    initrd /boot/initrd

###Don't change this comment - YaST2 identifier: Original name: linux###
title Kernel-3.11.6-4-desktop
    root (hd0,1)
    kernel /boot/vmlinuz-3.11.6-4-desktop root=/dev/disk/by-id/ata-TOSHIBA_MK8032GSX_X6IJF5AHS-part2    resume=/dev/disk/by-id/ata-TOSHIBA_MK8032GSX_X6IJF5AHS-part5 splash=silent quiet showopts
    initrd /boot/initrd-3.11.6-4-desktop
linux-sony:/home/zbyszek # 

I wonder if its possible that Grub 2 cannot work on my laptop? Do I really have to stick to Legacy Grub? Would be possible to add Linux Mint to its menu?
Thank you for any help and recommendations how to rectify my problems.

Yes, this might indeed be possible. We had a similar case here recently (with an older intel graphics chip).
You could try to play with the “Graphical Console” settings in YaST->System->Boot Loader->Boot Loader Options, I suppose.
I.e. try to set a specific resolution, or disable it completely.

You probably should file a bug report though.
http://bugzilla.novell.com/ (same username/password as here), or upstream at grub: GNU GRUB - GRUB Bugs .

Do I really have to stick to Legacy Grub? Would be possible to add Linux Mint to its menu?

Yes, this should be possible, unless Mint uses btrfs e.g. (AFAIK grub legacy doesn’t support that)
Just add a similar entry for Mint like the openSUSE ones to menu.lst (with the partitions changes appropriately of course).
You should be able to do that in YaST as well.

Probably something like this would do:

title Mint
    root (hd0,0)
    kernel /boot/vmlinuz root=/dev/disk/by-id/ata-TOSHIBA_MK8032GSX_X6IJF5AHS-part1    resume=/dev/disk/by-id/ata-TOSHIBA_MK8032GSX_X6IJF5AHS-part5 splash=silent quiet showopts
    initrd /boot/initrd


But that depends on how the kernel and initrd files are named in Mint.
Maybe mount the partition and post a directory listing if you need further help:

sudo mount /dev/sda1 /mnt
ls /mnt/boot

wolfi323 you suggested:

You could try to play with the “Graphical Console” settings in YaST->System->Boot Loader->Boot Loader Options, I suppose.
I.e. try to set a specific resolution, or disable it completely.

Tried to set a specific resolution: autodetected by grub, 1280x800, 1024x768, 1024x600, 800x600 640x480 NO MENU and finally I disabled it completely >>>>> SUCCESS. Grub 2 menu is shown OK. Even with Mint
Now I would like to prepare a bug report as you recommended. How much info I have to submit? I’ve never done it before.
Thank you for your help.

Good to hear! :slight_smile:

Now this is something I can really recommend the next time. Thanks for the feedback. :wink:

Now I would like to prepare a bug report as you recommended. How much info I have to submit? I’ve never done it before.

For openSUSE we have this guide:
https://en.opensuse.org/openSUSE:Submitting_bug_reports
Although, as you said you had the same problem with Mint, it might really be better to report it to grub directly, see my previous post.

And reporting bugs is not that complicated really.

Just describe your problem, and add some details like what Linux version you are using and (particularly in this case) the graphics chip. So maybe the output of “/sbin/lspci” would be good.
The developers will ask you if they need further informations.

If you need further assistance, feel free to ask here as well (but please provide a link to your bug report).

And remember: Don’t feel shy. This is a community after all. (yes, even the upstream developers… :wink: )
As long as you keep being friendly, there’s nothing you have to fear.
The worst thing that can happen is that the bug is being ignored, or closed as WONTFIX…

Note you should have a swap partition at least and it is also advisable to have a separate home but that is optional. You can share between destos but be sure that you use different user names sharing home can be problematic. If the directory use different versions of the desktop. Or use different desktop ie gnome on one KDE on the other. ie just don’t mix the config files that can lead to strange problems.

I’m very determined to report my bug to grub directly. I created and account with their web site. Spend a lot of time reading info available on GNU GRUB - GRUB Bugs but must say that I’m completely lost. I REALLY haven’t found a way how to submit my report !!! Even how to start the process of submitting ???
Could you help me a bit, please.

Since openSUSE mods grub (I think) it should be reported to openSUSE.

http://en.opensuse.org/Bugzilla

Go to GNU GRUB - Bugs: Browse Items [Savannah], log in, select Bugs - Submit.

But please understand that such bugs are near to impossible to solve without having access to the same hardware or possibilities to get out-of-band debugging output (serial port, network debugger). So do not hold your breath … reporting it to openSUSE bugzilla actually may have better chances.

I decided to report my bug to http://en.opensuse.org/Bugzilla rather than https://savannah.gnu.org/bugs/?group=grub. I’ll do this tonight.
Let me thank everybody who responded to my post. I feel that I’m in a good company and I would like to spread out good news about OpenSUSE and try to support it as much as I can.