grr, how to I disable a sound device in phonon?

I have two sound cards active on this machine and they both work fine. However I would like to blacklist one card from being used for audio capture in KDE, because I am already using it outside of KDE for timed recording. The problem is that when I start amarok while timed recording is going on, it attempts to probe the card and this causes the recording to abort.

In Configure desktop > Multimedia, I can see the two cards. I can alter the priority but the Remove button is greyed out. So I can’t remove a card from phonon.

Searching around for where phonon stores its configuration led me to ~/.config/ This certainly looks like the info I was trying to edit, but it’s encoded in some way:

$ cat .config/



Great, thanks very much KDE4, what program do I need to edit this? Is this functionality that is yet to come?

Hi Ken, you know so much more than I about Linux that I’m somewhat reluctant to suggest much, as I suspect you have already tried it. :slight_smile:

You can black list the sound driver in /etc/modprobe.d/50-blacklist.conf but that will stop all functionality from that device, and I suspect that you wish to retain some functionality (its just the phonon aspects you wish to stop).

Does changing the card priority under YaST > Hardware > Sound help (per step 9 in the troubleshooting guide): SDB:AudioTroubleshooting - openSUSE - step9 help ?

You could try asking on freenode IRC #alsa or IRC #kde to see if anyone there has a suggestion.

I want the card to be active, I just don’t want phonon to use it for audio capture. It’s already the second card on the list, but it still appears on phonon’s list of devices. I can’t remove it from the module list. That would make it effectively not installed.

There was mention of a kmc_phonon app somewhere to edit phonon preferences. I’ll search again later. Maybe it’s one of the things that isn’t implemented yet in this version of KDE.

It is possible to select which card does the recording in the mixer, but I do not think it will stop alsa from probing the card … and I note this:

I suspect switching OFF in the mixer the 2nd card’s recording will not stop the probe that is causing the problem. I assume you already tried that.

Possibly IRC freenode #kde may be the best place to try, but areas such as sound and phonon is sort of a “interface” area between the desktop and the sound driver, and interfaces are always tricky to find a solution for.

I don’t think it’s ALSA that’s probing the card, that all was finished when the drivers were loaded, but phonon, from xine, from amarok. I think what happens is that phonon or xine tries to grab the recording channel and this causes the other program (arecord) to exit because it cannot read the device. For the moment I can just be careful not to start amarok while a cron recording is in effect.

FYI, this is the kernel messge:

[424148.835056] ALSA /usr/src/packages/BUILD/kernel-desktop- capture write error (DMA or IRQ trouble?)

may need to ask for the feature in openFATE (or employ a second
machine? hmmmm…is it possible to assign one card to a VM, only and
then run that task in that separate ‘machine’?)…


Nah, that’s overkill. All I want is for phonon to not use this card for audio capture. The fact that there is a greyed out remove button suggests that editing the device list is unimplemented functionality.