growisofs in cron script

I want to run an unassisted backup at night to DVD+RW media using cron. I run a script containing the line:

/usr/assist/bin/growisofs -Z /dev/dvd -dvd-compat -J -r -pathspec /aaa/bb/cccc

When I execute the script from the command line, it runs just fine, and overwrites the media.

When I kick the same script off in cron, it logs:

FATAL: /dev/dvd already carries isofs!

I have tried a few other options, but no luck.

Ah yes, I found this out a while back. The man page for growisofs says this:

If the media already carries isofs and growisofs is invoked with -Z option non-interactively, e.g. through cron, it shall fail with “FATAL:/dev/dvd already carries isofs!” Note that only ISO9660 is recognized, you can perfectly zap e.g. an UDF filesystem non-interactively. Recommendation is to prepare media for unattended usage by re-formatting or nullifying first 64KB in advance.

The suggested solution is to zap the first 64kB like this:

dd if=/dev/zero count=128 of=/dev/sr0

Thanks ken_yap!

Briliant!!!