Groundhog Day: Installation from DVD always goes back to selection menu

I downloaded the latest ISO image for Leap 42.3 and burned it to DVD. When I boot my computer with the DVD in the drive, a selection menu appears:
Boot from harddrive
<other options>

When I chose “Installation”, all seems fine at the beginning. The screen turns into a ‘console mode’ after some time and then goes black. I now expect the installation to start… instead, I’m back at the selection menu of the DVD.

The DVD is fine, I can use it on another (older) desktop computer.
I still have the DVD with Leap 42.2 and I can install Leap 42.2 from this DVD without any issues.

I also have a multi-boot DVD with several linux distributions. Same problem there, regardless of the distribution I chose (I tried Tumbleweed and Ubuntu).
I therefore assume that the problem is not specific to Leap 42.3, but to the combination of my desktop with ‘new’ ISO images.
Any idea where to look?

Thanks, Stephan

What video card???

Trinity [Radeon HD 7540D]

Maybe disable plymouth or try booting with nomodeset via grub options?

What system hardware is this, is it Legacy or UEFI booting?

Have you tried a net install rather than DVD?

If you can install openSUSE Leap 42.2, could look at installing that, switch the repos to 42.3 and doing a zypper dup.

Problem solved!
I tried to start the installer in text mode. That didn’t help.
I then tried the kernel without ACPI and that worked!.

Thanks, Stephan