Grey Login Screen and Plasma 5 Crashes after Upgrade

I did an upgrade to LEAP 42.1. During the upgrade, it removed my nvidia drivers for my GeForce 210 card. So I added the repository back in and re-installed them before I was even able to get the GUI up. Afterwards I was getting a grey login screen with Opensuse logo and a console in the lower-right corner. I think this is the xdm screen, and so I checked the /etc/sysconfig/displaymanager and it was set to kdm. I tried gdm, but all I got was a critical error/crash screen, so set it back to kdm but still got the grey login screen.

Logging in it’s defaulting to KDE (as it was before) but it looks like Plasma 5 crashes hard. If I have no windows open, I get nothing but blacked-out and garbled graphics. If a screen opens up I get the window just fine, and can see the crash manager in the background about Plasma experiencing a problem (but can’t seem to get to it).

I then proceeded to march forward and upgrade to 42.2… with the mild hope that it would fix it (not totally unguided here, as there were a few forum posts about Plasma for 42.1 not working due to a couple known version bugs). But no dice. Same issue persists. Here’s the nvidia packages I currently have installed:


nvidia-computeG03-340.102-6.1.x86_64
nvidia-uvm-gfxG03-kmp-default-340.102_k4.4.27_2-6.1.x86_64
x11-video-nvidiaG03-340.102-6.1.x86_64
nvidia-glG03-340.102-6.1.x86_64
nvidia-gfxG03-kmp-default-340.102_k4.4.27_2-6.1.x86_64

Currently running the 4.4.57-18.3-default kernel. What I don’t understand is if I’m running this kernel, why is the nvidia driver saying 4.4.27_2-6.1? Here’s my kernel packages:


>rpm -qa | grep kernel
patterns-openSUSE-devel_kernel-20150918-25.1.x86_64
kernel-syms-4.4.57-18.3.1.x86_64
kernel-default-4.4.57-18.3.1.x86_64
kernel-devel-4.4.57-18.3.1.noarch
kernel-macros-4.4.57-18.3.1.noarch
kernel-default-devel-4.4.57-18.3.1.x86_64
texlive-l3kernel-doc-2015.105.svn_5724svn38014-21.2.noarch
kernel-firmware-20160516git-5.1.noarch
kernel-source-4.4.57-18.3.1.noarch
texlive-l3kernel-2015.105.svn_5724svn38014-21.2.noarch

Here’s what repositories I currently have installed/enabled:

 
>zypper repos --uri
Repository priorities are without effect. All enabled repositories share the same priority.

#  | Alias                             | Name                                    | Enabled | GPG Check | Refresh | URI
---+-----------------------------------+-----------------------------------------+---------+-----------+---------+----------------------------------------------------------------------------
 1 | Mono-openSUSE-Leap-42.2           | Mono-openSUSE-Leap-42.2                 | Yes     | (r ) Yes  | Yes     | http://download.opensuse.org/repositories/Mono:/Factory/openSUSE_Leap_42.2/
 2 | PlexRepo                          | PlexRepo                                | No      | ----      | ----    | https://downloads.plex.tv/repo/rpm/x86_64/
 3 | download.nvidia.com-opensuse      | nVidia Graphics Drivers - leap/42.2     | Yes     | (r ) Yes  | Yes     | ftp://download.nvidia.com/opensuse/leap/42.2/
 4 | openSUSE-Leap-42.2-Update         | openSUSE-Leap-42.2-Update-oss           | Yes     | (r ) Yes  | Yes     | http://download.opensuse.org/update/leap/42.2/oss/
 5 | openSUSE-Leap-42.2-Update-Non-Oss | openSUSE-Leap-42.2-Update-Non-Oss       | Yes     | (r ) Yes  | Yes     | http://download.opensuse.org/update/leap/42.2/non-oss/
 6 | packman-essentials                | packman-essentials-leap/42.2            | Yes     | (r ) Yes  | Yes     | http://packman.inode.at/suse/openSUSE_Leap_42.2/Essentials/
 7 | packman-leap/42.2                 | packman-openSUSE-leap/42.2              | No      | ----      | ----    | http://packman.jacobs-university.de/suse/openSUSE_Leap_42.2/
 8 | packman-leap/42.2_inode.at        | packman-leap/42.2_inode.at              | Yes     | (r ) Yes  | Yes     | http://packman.inode.at/suse/openSUSE_Leap_42.2/
 9 | packman-multimedia                | packman-multimedia-leap/42.2            | Yes     | (r ) Yes  | Yes     | http://packman.inode.at/suse/openSUSE_Leap_42.2/Multimedia/
10 | repo-debug                        | openSUSE-leap/42.2-Debug                | No      | ----      | ----    | http://download.opensuse.org/debug/distribution/leap/42.2/repo/oss/
11 | repo-debug-update                 | openSUSE-leap/42.2-Update-Debug         | No      | ----      | ----    | http://download.opensuse.org/debug/update/leap/42.2/
12 | repo-debug-update-non-oss         | openSUSE-leap/42.2-Update-Debug-Non-Oss | No      | ----      | ----    | http://download.opensuse.org/debug/update/leap/42.2-non-oss/
13 | repo-leap/42.2-non-oss            | openSUSE-leap/42.2-Non-Oss              | Yes     | (r ) Yes  | Yes     | http://download.opensuse.org/distribution/leap/42.2/repo/non-oss/
14 | repo-leap/42.2-oss                | openSUSE-leap/42.2-OSS                  | Yes     | (r ) Yes  | Yes     | http://download.opensuse.org/distribution/leap/42.2/repo/oss/
15 | repo-source                       | openSUSE-leap/42.2-Source-oss           | No      | ----      | ----    | http://download.opensuse.org/source/distribution/leap/42.2/repo/oss/
16 | virtualbox-leap/42.2              | VirtualBox leap/42.2                    | No      | ----      | ----    | http://download.virtualbox.org/virtualbox/rpm/opensuse/leap/42.2/

I’ve tried re-installing the nvidia drivers… but doesn’t seem to change anything. I also tried editing the $HOME/.config/kwinrc for OpenGLIsUnsafe=true as suggested in another thread I found on this forum… still no good.

I’m not sure what to try or where to go next. :\

How did you upgrade? Or did you rather install fresh?

kdm is not installed by default any more (though it shouldn’t get removed on upgrades), sddm is the KDE default since 42.1.
Install kdm manually and you should get the kdm login screen.

I then proceeded to march forward and upgrade to 42.2… with the mild hope that it would fix it (not totally unguided here, as there were a few forum posts about Plasma for 42.1 not working due to a couple known version bugs). But no dice. Same issue persists.

Please post the file /var/log/Xorg.0.log, and the output of “glxinfo|grep render” (you may have to install Mesa-demo-X first).

You could also try to install the G02 driver instead. There was at least one user recently who had problems with G03 (though the card should have been supported), but G02 worked…
But please remove the G03 packages first, and then install G02 in a second step.

Currently running the 4.4.57-18.3-default kernel. What I don’t understand is if I’m running this kernel, why is the nvidia driver saying 4.4.27_2-6.1?

Because 42.2 shipped with kernel 4.4.27, but that doesn’t matter. The kernel module is compiled for your running kernel anyway when you install it.

Btw, you can remove these repos:

 
 6 | packman-essentials                | packman-essentials-leap/42.2            | Yes     | (r ) Yes  | Yes     | http://packman.inode.at/suse/openSUSE_Leap_42.2/Essentials/
 9 | packman-multimedia                | packman-multimedia-leap/42.2            | Yes     | (r ) Yes  | Yes     | http://packman.inode.at/suse/openSUSE_Leap_42.2/Multimedia/

They are pointless if you have the full Packman repo anyway.

I did the upgrade using zypper dup from 13.2. If kdm is not the default, I’m good with running sddm as the new manager (anything has to be better than xdm). I’ve set the manager to sddm and now the login manager seems to work great! Thanks!

Please post the file /var/log/Xorg.0.log, and the output of “glxinfo|grep render” (you may have to install Mesa-demo-X first).

Here is the Xorg.0.log: https://paste.opensuse.org/b077a444

I can’t execute glxinfo|grep render… I get “Error: unable to open display”.

You could also try to install the G02 driver instead. There was at least one user recently who had problems with G03 (though the card should have been supported), but G02 worked…
But please remove the G03 packages first, and then install G02 in a second step.

I’ve run the G03 for years, but gave G02 a try. No luck. Same issues. I then reverted back to G03.

It’s also worth noting that now that I had a login manager, I was able to try GNOME and IceWM. Trying to start Grome, I get the “OH NO! Something Failed!” screen and get booted back to the login manager after clicking Ok. IceWM I can start and seem to have full access to.

Because 42.2 shipped with kernel 4.4.27, but that doesn’t matter. The kernel module is compiled for your running kernel anyway when you install it.

Btw, you can remove these repos:

 
 6 | packman-essentials                | packman-essentials-leap/42.2            | Yes     | (r ) Yes  | Yes     | http://packman.inode.at/suse/openSUSE_Leap_42.2/Essentials/
 9 | packman-multimedia                | packman-multimedia-leap/42.2            | Yes     | (r ) Yes  | Yes     | http://packman.inode.at/suse/openSUSE_Leap_42.2/Multimedia/

They are pointless if you have the full Packman repo anyway.

Perfect. Thanks for the info, and I’ve also removed the two additional repos. Cheers.

A “zypper dup” should not replace/uninstall kdm though (unless there are conflicts).

As mentioned, you should be able to get back kdm by installing it manually.

But if sddm suits you too, fine.

Here is the Xorg.0.log: https://paste.opensuse.org/b077a444

The driver seems to work.
I note that you use an /etc/X11/xorg.conf, you may try to remove (or better rename) it in case it’s caused by some of your settings.

I can’t execute glxinfo|grep render… I get “Error: unable to open display”.

How/where did you try to run it?
You need to do it inside a graphical session (icewm e.g.), as the logged in user (i.e. not root via su or sudo).

It’s also worth noting that now that I had a login manager, I was able to try GNOME and IceWM. Trying to start Grome, I get the “OH NO! Something Failed!” screen and get booted back to the login manager after clicking Ok. IceWM I can start and seem to have full access to.

GNOME requires working OpenGL too, yes.

Though I find that a bit strange now. SDDM would need working OpenGL support as well, just like Plasma (it’s actually a requirement of Qt5’s QML/QtQuick) and GNOME.
And from what you wrote so far, it looks like that seems to be not working (hence why I ask for the output of glxinfo).

How/where did you try to run it?
You need to do it inside a graphical session (icewm e.g.), as the logged in user (i.e. not root via su or sudo).

Sorry, I originally tried running glxinfo from the login manager using the Ctrl+Alt+Function Key as I could not access any login. But I was able to run it in IceWM and here’s the output:


>glxinfo | grep render
direct rendering: Yes
OpenGL renderer string: GeForce 210/PCIe/SSE2
    GL_KTX_buffer_region, GL_NVX_conditional_render, GL_NVX_gpu_memory_info, 
    GL_NV_ES1_1_compatibility, GL_NV_blend_square, GL_NV_conditional_render, 
    GL_NV_parameter_buffer_object2, GL_NV_path_rendering, 
    GL_KTX_buffer_region, GL_NVX_conditional_render, GL_NVX_gpu_memory_info, 
    GL_NV_ES1_1_compatibility, GL_NV_blend_square, GL_NV_conditional_render, 
    GL_NV_parameter_buffer_object2, GL_NV_path_rendering, 
    GL_OES_element_index_uint, GL_OES_fbo_render_mipmap, 

The driver seems to work.
I note that you use an /etc/X11/xorg.conf, you may try to remove (or better rename) it in case it’s caused by some of your settings.

I remember I had to setup an xorg.conf years ago when I used to run KODI from this system. It didn’t interact with my TV very nicely until I had the Xorg.conf in there.

After producing the glxinfo shown above, I moved the file and rebooted the system. Came back up and Plasma 5 KDE Worked!!! Awesome! I logged out, and tried Gnome as well, and no longer any issues! Thanks a ton!:good: