Gray Login Screen - KDE Doesn't Load

I’m not certain if I’ve installed any sort of updates that have borked my system but when it loads I get this screen:
Photo by charlieoliver • Instagram

I got this out of messages: Paste2 - Viewing Paste 2478196

I can start KDE but only if I do “sudo startx”
I can’t run it while in superuser mode though, I get something close to: Paste2 - Viewing Paste 2474681

I’ve attempted to update my ATI drivers to the latest FGLRX ones (v 9), to correct but that didn’t address anything…

Any ideas? Really can’t come up with anything else to look at.

Oh, I’m on 12.2, I upgraded from 12.1 a few weeks ago.

Does not appear to be a graphic driver issue.

Do you ever log into a GUI as root. If so DON"T you can mess up file ownership

Did you change the default login screen somewhere?

What happens when you type your user name? Does it then ask for password or have you set no password required some where?

In a terminal log in as root or become root with su -

type Yast go to the etc/sysconfig editor and look at Desktop-display manager and see if things look right.

Also you could add a new user and see if they can log

Check the ownership of the files in your home see if any are owned by root. If so change them to the user.

.

No, just since I haven’t been able to log in as myself have I been doing this.

It does ask me for a password, but then it dumps me to a terminal.

I did notice that the window manager didn’t seem to be assigned to anything, so I assigned it to KDE and its now properly kicking me to a KDE screen (although I have a default user set so there is something going awry there)

Tried a new user and no go.

I went to the home directory and have changed all files to my user, there weren’t very many or any system related files that I could tell

Recap: I now get a proper KDE login screen instead of the one pictured, but even when I log in via that screen I still am getting dumped to a terminal.
All files in my users directory have been set to my user (I selected the directory and had it recursively go through and assign them).

I can’t really understand this entire post but it sounds similar, anyone able to interpret?

linux’d again …

I tried setting the correct permissions via X.Org Wiki - FAQMiscellaneous

Now it seems the failsafe is being triggered. When I boot up, I eventually end up with a black screen sans 1/9th that is a console window that appears to be frozen.
I can switch to other sessions however and can still “sudo startx” to get into GUI.

Maybe I’ll post another dump from the logs…

Messages:
Paste2 - Viewing Paste 2479532

Xorg.0.log
Paste2 - Viewing Paste 2479534

warn
Paste2 - Viewing Paste 2479537

So, that blog essentially says that xserver has the wrong permissions to start. Did you look at the /var/log/Xorg.0.log?
Did you start from rescue cd and run fsck on the drives to repair errors?

I am not sure what to tell you at this point since you have changed all the permissions on the drive.

One could try re-install of kdm or xorg but from the log you posted you do not have internet connection.
Otherwise the command to re-install kdm as a normal user would be,

sudo zypper in -f kdm

There is a minor bug where recursive option doesn’t always work when changing permissions from root+root to user+users.
Not sure if that’s KDE or dolphin specific. I did notice this bug several times.

Steps to reproduce:

Add some root owned files and folders into user home and set recursive permissions of /home/username to username+users.
Open /home/username and the files and other folders inside are sometimes (not always) still owned by root+root.

Workaround:

Enable hidden files display and detailed permission display in dolphin to manually check the permissions.
Then set recursive user permissions on each missed folder if there is any.

Not sure if this solves your problem, just saying I’ve seen it happen before.

Ok

try adding a new user the KDE configs may be messed and this will tell use if that is so

Try not to thrash around and try anything you find on the web. You have to be systematic. You can do more damage by just trying random things. And mostly that won’t work.

On 2012-11-14 19:36, charlieoliver wrote:
>
> Oh, I’m on 12.2, I upgraded from 12.1 a few weeks ago.

Which method?

Online upgrade
method

Offline upgrade
method


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” (Minas Tirith))

On 2012-11-15 01:46, charlieoliver wrote:
>
> I tried setting the correct permissions via ‘X.Org Wiki -
> FAQMiscellaneous’ (http://www.x.org/wiki/FAQMiscellaneous)

Have you enabled secure settings, perchance?


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” (Minas Tirith))

@robin_listas: I did the online upgrade

If I’m not sure what those are, could I have enabled them accidentally?

Yeah, I have internet, not sure why, it not working is the same thing I get too. So I’ve re-installed kdm, to no joy.

I’ve just finished running fsck as well to no joy.

Current Status:
When I boot up, I immediately fall into failsafe. Or at least what I think is failsafe. It loads a white console window that I can’t interact or type into.
I hit ctrl-alt-f1 to get to console and log in as my user then run the following commands (the final one is the only one that works the rest output a serverauth not found error).
startx
su
startx
sudo startx

The final command loads KDM.

On 2012-11-15 18:26, charlieoliver wrote:
>
> robin_listas;2503955 Wrote:
>>
>> Have you enabled secure settings, perchance?
>>
> If I’m not sure what those are, could I have enabled them accidentally?

You might, it is one of the settings in YaST.


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” (Minas Tirith))

On 2012-11-15 17:16, charlieoliver wrote:
>
> @robin_listas: I did the online upgrade

You might have to review the .rpmnew and .rpmsave files.


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” (Minas Tirith))