Graphics problems

I am having graphics problems with leap.
Computer is an XPS M1710.
I was having issues with Tumbleweed as I installed that first. My computer would randomly restart. At one point I thought I might have found some correlation to when notifiers would pop up like facebook, email or update notifications. I have always hated and had trouble with Nouveau and I figured it might be related. I didn’t want to deal with the hassle of installing Nvidia on Tumbleweed so Installed Leap and the Nvidia drivers. Everything seemed fine for a while and then I noticed strange things starting to happen. Sometimes when I sent an email in thunderbird the sending email progress window wouldn’t disappear. I could click on another window and the progress window would fall behind the selected window but it would stay there till I rebooted. Then I noticed others did the same. Not all the time but a lot of the time.
I installed Nod 32 antivirus and it’s update notifications will do it sometimes. If I try to save something in Gimp it will save but the save window will not go away.
I tried playing with composting settings. I changed the rendering backend settings. I changed opengl settings. I tried changing everything I could. Finally I realized the disabling the compositer made the stuck screens go away but even with compositing disabled they can show back up so disabling compositing doesn’t fix the problem but toggling the compositer on or off does make them go away.
Today I also had some things on the screen look scrambled. Kind of like TV snow but multi colored.

I have never been able to get Linux to run well on this machine. Or my old XPS M1710 for that matter. On this M1730 I have tried Kubuntu, Fedora, and Open Suse. Granted always KDE installs because well I want to run KDE. I have had strange problems and stability issues with all of them making none of them suitable options. It is dual boot with Win7 which got upgraded to Win10 and aside from being Windows slow I have never had any issues with Windows.

I’m a little puzzled that you managed to install LEAP because, according to the Dell Owner’s manual for the XPS M1710, it has a 32 bit processor whereas LEAP requires a 64 bit processor or have you a later (64 bit) version of the chip that was originally supplied with the XPS M1710?

If you really have a 32 bit processor, you can only run 13.2 or Tumbleweed.

My current computer is the M1730. I just brought up the 1710 because neither computer has seemed to get along well with Linux. I hadn’t tried Suse on the 1710 but had tried Kubuntu and Fedora numerous times and possibly others. I have now tried Open Suse, Fedora, and Kubuntu on this computer and have had issues with all. I have really come to like Open Suse now and would like to stay with it but need to figure out this issue to really consider it a viable option.

Pretty sure the 1710 is 64 bit. The 1730 definitely is.

Have checked again and the XPS M1710 was supplied with a 64 bit processor but also, like the 1730 with Nvidia GeForce graphics which I suspect is at the heart of your graphics problems - which have been longstanding for Linux users. You probably need advice from someone with long experience of Nvidia and/or the Nouveau drivers.

So that’s it? Just blame Nvidia?
I have never heard of issues with the Geforce graphics cards with Nvidia drivers.

You haven’t mentioned which Nvidia driver you have installed?

Are you using the G03 drivers?

As a test I would try out the 304.131 driver.