Graphics driver not loading quickly enough for plymouth?

Hardware is Lenovo G50-45 laptop. AMD A8 which I believe is a Radeon R5 GPU. It appears that after a kernel upgrade, plymouth works as it is supposed to and I am greeted with the openSUSE theme, just for the first boot. After that, plymouth falls back to a screen with only 3 progress dots. plymouth never fails to display the theme during shutdown, so I am guessing that whichever driver a Radeon R5 needs is not loading quickly enough during boot, or possibly plymouth needs to wait until it is fully loaded. Once fully booted, everything works well and I am able to use desktop effects without a glitch. This behavior is identical in Leap 15.2 beta. Any suggestions?

Actually erroneous information. I upgraded the kernel in 15.2 and plymouth has worked correctly several times. I’m not sure what technical differences there may be between the default 15.1 theme and the 15.2 theme. They are very different in appearance.

susepaste -n purevw /var/log/Xorg.0.log

should upload the server log so that we can see what is happening in X. If you get a file not found message, try instead:

susepaste -n purevw ~/.local/share/xorg/Xorg.0.log

Either way, report here the URL that results from running that command. It’s possible additional info to help us help you could come from doing the following in addition:

sudo journalctl -b | susepaste -n purevw

If susepaste gives you trouble, you can upload the files using the web browser interface at http://susepaste.org. If still having any trouble, try getting us this output:

sudo inxi -SGxxxza

Please use code tags around any command output you paste in here. Use zypper or yast to install inxi if command not found results from trying.

No. The problem exists for years, it comes and goes. As this is race condition, any change in your system (different kernel, different drivers) may slightly change timings so problem appears to be fixed just to come back later.

How Xorg is related to plymouth in initrd?

It addresses the thread topic “graphics driver”. The kernel’s KMS driver AFAICT could be playing a part in plymouth behavior. We don’t know to which graphics driver the author’s subject might refer.

My Xorg.0.log from 15.1
https://susepaste.org/57086019

My journalctl -b output from 15.1
https://susepaste.org/41506194

Both OSs on this machine seem consistent. 15.1 fails every time and 15.2 succeeds every time. As far as I can tell, all boot parameters and kernel parameters are identical between the two. I do not have a kernel scheduler preference set in either OS. splash=silent quiet on both

I apologize. I am not using any 3rd party driver. I didn’t state it earlier. I did an “lsmod” to grep radeon. It shows both amdgpu and radeon loaded, but both Leap versions 15.1 and 15.2 show the same. Not sure if it is of any use, but I’ll paste it here:


ronnie@Lenovo:~> lsmod | grep radeon
radeon               1646592  39
i2c_algo_bit           16384  2 amdgpu,radeon
drm_kms_helper   241664  2 amdgpu,radeon
ttm                     122880  2 amdgpu,radeon
drm                     552960  14 gpu_sched,drm_kms_helper,amdgpu,radeon,ttm

Try appending these options to the linux line at the grub menu:

radeon.cik_support=0 amdgpu.cik_support=1

I don’t think you want to see both radeon and amdgpu show up in lsmod output. With device 1002:9851 Mullins, driver use should be amdgpu only AFAICT. If this works, those options need to be included in /etc/default/grub’s GRUB_CMDLINE_LINUX_DEFAULT= line, and grub.cfg regenerated.

Hi
I just use one option for mullins;


 /sbin/lspci -nnk | egrep -A3 "VGA|Display|3D"

00:01.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Mullins [Radeon R3 Graphics] [1002:9850] (rev 40)
    Subsystem: Hewlett-Packard Company Device [103c:8305]
    Kernel driver in use: amdgpu
    Kernel modules: radeon, amdgpu

GRUB_CMDLINE_LINUX_DEFAULT="splash=silent quiet ipv6.disable=1 amdgpu.cik_support=1 mitigations=auto"

Still no joy, but I have a bit more info. After the grub changes, I got a single successful boot, then back to failure. Before the change, I had:

00:01.0 **VGA** compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Mullins [Radeon R4/R5 Graphics] [1002:9851] (r
 ev 05) 
       Subsystem: Lenovo Device [17aa:3801] 
       Kernel driver in use: radeon 
       Kernel modules: radeon, amdgpu
  

After the change, Kernel driver in use became amdgpu.
On the successful boot, the last console message before plymouth was:

hardware watchdog disabled

Subsequent boots show as last message:


May 08 11:23:04 Lenovo kernel: kfd kfd: MULLINS  not supported in kfd

I reverted grub to the way it was. That eliminated the kfd error. The problem still exists, but with 15.2 final version only 2 months out, it seems that I am wasting people’s time for a problem that will be very short-lived. I have changed plymouth to use the “details” theme, which is a verbose type of output, but at least it works consistently. I appreciate everyone’s input.

Is there any reason you want to run Plymouth?

For me booting was that fast that I did not see a need for Plymouth and disabled it:


> sudo zypper rm plymouth plymouth-plugin-label plymouth-plugin-script plymouth-scripts plymouth-plugin-two-step
> sudo zypper addlock plymouth

Running now with that for about a year and no side-effects seen.

FWIW purevw, I’ve never seen a poll among regular contributors here, but I have a sense that maybe most do as marel and either remove Plymouth, or do as I do, and don’t let it get installed in the first place. Consequently, there may not be a lot of direct experience with any kind of trouble using it.

To me Plymouth is pure bloat. OTOH, I like seeing boot messages in nice legible kernel native text that keeps the brain occupied seeing some of the things that are actually happening during the few seconds the OS is starting up.

I am similar. Especially after a kernel update, I’ll hit the Esc key to bypass plymouth and get a verbose display and spot any possible warnings or failures during the first boot. My machines that the public don’t see typically run either LXDE desktop, IceWM, or even runlevel3.
I try very hard to get people interested in openSUSE and Linux in general, and use my laptop as a display machine. I have 3 versions of Windows, openSUSE, linuxmint, Ubuntu, and ghostBSD installed. The average person doesn’t want to see things that confuse them, or that they don’t understand. It turns them away quickly. They want “pretty” things such as plymouth and desktop effects to an extreme, and they want “uncomplicated”. It’s very hard to sell an OS using console output as an example, although I tell them that the console can be their best friend when there is a problem.

Plymouth works flawlessly on the i7-6700K. However an error is flashing:

 0.044948] kernel: DMAR: [Firmware Bug]: No firmware reserved region can cover this RMRR [0x0000000078800000-0x0000000088ffffff], contact BIOS vendor for fixes

Asrock will not fix an error on a board 4 years old. Thus I de-installed and locked plymouth. Boot is pretty fast now:


erlangen:~ # systemd-analyze critical-chain 
The time when unit became active or started is printed after the "@" character.
The time the unit took to start is printed after the "+" character.

graphical.target @4.178s
└─display-manager.service @3.303s +874ms
  └─apache2.service @3.128s +170ms
    └─time-sync.target @3.110s
      └─chronyd.service @3.029s +79ms
        └─network.target @3.026s
          └─wicked.service @1.805s +1.219s
            └─wickedd-nanny.service @1.791s +12ms
              └─wickedd.service @1.752s +37ms
                └─wickedd-dhcp4.service @1.716s +35ms
                  └─network-pre.target @1.713s
                    └─firewalld.service @1.267s +446ms
                      └─polkit.service @1.157s +106ms
                        └─basic.target @1.132s
                          └─sockets.target @1.130s
                            └─pcscd.socket @1.129s
                              └─sysinit.target @1.110s
                                └─apparmor.service @516ms +592ms
                                  └─var.mount @492ms +20ms
                                    └─local-fs-pre.target @462ms
                                      └─systemd-tmpfiles-setup-dev.service @448ms +11ms
                                        └─kmod-static-nodes.service @399ms +32ms
                                          └─systemd-journald.socket
                                            └─system.slice
                                              └─-.slice
erlangen:~ #