Graphics Driver Change in openSUSE 13.1 GNOME

Where do I find the option to change the graphics driver in openSUSE 13.1 GNOME?

I know that I can go through this >> https://en.opensuse.org/SDB:NVIDIA_drivers but I didn’t know if I can look at what is pre-installed on the Live ISO.
Thanks!

You might tell us what kind of graphics card you have, and what driver you are running right now, and which one you want. Install the package Mesa-demo-x, and then run the following command as a normal user:

glxinfo | grep -i opengl

Paste the output here.

The recommended solution is to add “nomodeset” to the boot command line while booting the installer. Or, if that option exists, hit the graphics mode function key (I think it is F3) and select “NoKMS”.

That gives you a workable boot for installing. You can add the Nvidia drivers later.

There is no option in GNOME to change the graphics driver.

So you have an nvidia card and want to switch to the nvidia driver?

Well, it is not on the Live ISO, so you are most likely using nouveau.
You can have a look in GNOME’s settings->Details, this should show which graphics driver is used.

If you want to use the nvidia driver, just install it and it should be used automatically.
But this probably won’t work on a Live ISO.
If you copied it to an USB drive, you could actually install it (you obviously can’t on a DVD :wink: ), but I’m not sure if the writeable overlay is mounted in time for the driver to work.

I’m currently running a nVidia Geforce GTS 250 on the GNOME Live ISO. The video works fine with whatever it uses by default, other than the GPU fan runs high until I install the proper nVidia driver. It’s this way on all the other Linux distro’s I’ve used on this PC, so that’s not uncommon.
I’m just used to opening the “Additional Drivers” menu in other distro’s and selecting whatever drivers I need for the GPU/WiFi/etc :slight_smile:

Thanks!

Yessir

Makes sense. I’ll see if I can proceed with the openSUSE 13.1 GNOME install and go from there. Thanks!

Yes it is, though I have not tested that. The overlay is mounted very early. But it is too late to affect the actual loading of a kernel. It might be too late to blacklist “nouveau”, so perhaps you would still need “nomodeset” on the boot command line. It is mounted well before X is started.

Hi
I just resurrected my old AMD X24400+ today and dropped a Nvidia 8800GT I had lying around for giggles, the latest nvidia blob blacklists the nouvea driver in the script, I just needed to reboot after setting;


systemctl set-default multi-user.target
shutdown -r now

When the system came back up, logged in as root user, then;


sh NVIDIA-Linux-x86_64-340.32.run -a
systemctl set-default graphical.target
mkinitrd
shutdown -r now

Right, I knew that.
I was rather worried about the initrd/plymouth.
If that initializes the graphics before the overlay is there, nouveau will be loaded and prevents the nvidia driver from working.