Graphics card recommendations?

I need a new graphics card. Mine is an ATI Radeon 9500 series with just 128MB of onboard memory. I’m not playing games or doing any video editing, but I do sometimes with with large images or watch movies. What’s a good entry-level or midrange graphics card that works in OpenSUSE?

I need a new graphics card. Mine is an ATI Radeon 9500 series with just 128MB of onboard memory. I’m not playing games or doing any video editing, but I do sometimes with with large images or watch movies. What’s a good entry-level or midrange graphics card that works in OpenSUSE?
So there is no doubt right now that I recommend you buy an nVIDIA based GPU and load the nVIDIA proprietary video driver for the absolute best video performance in Linux, in my opinion (of course). Right now, for a mid priced video card I would go for a card based on the nVIDIA GTX 550 Ti card. They list around $150, but I found one for $140 at a local dealer. Next up, if a nVIDIA GTX 460 priced around $180, but it depends on the amount of memory and if over clocked or not. Both are double wide cards. The 550 needs a single six pin power plug while the 460 requires two six pin power connections. Here is an article that compares several video cards including the 450 and 550:

AnandTech - NVIDIA’s GeForce GTX 550 Ti: Coming Up Short At $150

Now keep in mind what you are asking for. While the 550 Ti might be a little short for super game playing, it works great with openSUSE and anything you can throw at from Linux. The price is right and the power usage not as high as a 460, which is a nice card as well. When I read such reviews, all are looking at a $700 nVIDIA 590 dual GPU video card that may require a 1000 watt power supply just to make it work. I have a 500 watt with the GTX 550 Ti which works just fine. And they work just fine with Linux and openSUSE.

The 550 supports dual monitors and has one hdmi connection, though the exact setup depends on who packages the GPU board as several manufacturers do so. So check out nVIDIA and never look back. Make sure you know your power supply size and if your PC can handle PCIe video cards. Good luck…

Thank You,

Thanks for the advice. My motherboard does have PCIe (if I’m reading this chart correctly: ASUSTeK Computer Inc. - Motherboards- ASUS P8P67 DELUXE) so I will give the 550 a try.

My power supply is 430 watts. That should be plenty, correct?

Thanks for the advice. My motherboard does have PCIe (if I’m reading this chart correctly: ASUSTeK Computer Inc. - Motherboards- ASUS P8P67 DELUXE) so I will give the 550 a try.

My power supply is 430 watts. That should be plenty, correct?
First off, that motherboard you have will be SUPER! It is one of the best out there in its price rage, so congratulations on your selection. As for the power supply, the minimum recommended size is 400 watts, so 430 will also be fine. Here are the specs from one company:

ZOTAC AMP! GeForce GTX 550 Ti 1GB 192-bit GDDR5 (1000 MHz/4400 MHz) Graphics Card [ZT-50402-10L]

In the review, the card could draw a maximum of 116 watts total if you are pushing it hard playing a game. All that means to me is make sure your case cooling fans are working properly and not blocked if you are pushing the card to its max. The be truthful, I am not sure I have even pushed the card that hard in Linux, but it is good to know the power is there if you need it.

When you get it, you will need instructions on loading the nVIDIA driver. I happen to load the driver the hard way as it is know, which to quote another user here who also adds, that it is not hard to load. Here is an article on loading the nVIDIA driver:

SDB:NVIDIA drivers - openSUSE

Here is the pointer to loading it the hard way:

SDB:NVIDIA the hard way - openSUSE

I happen to have written a bash script useful in loading the driver the hard way you can find here:

LNVHW - Load NVIDIA (driver the) Hard Way from runlevel 3 - Page 2

Just ask questions about anything you do not understand and get ready for a super fast video experience. While waiting on the video card, why not consider getting your multimedia in order by reading through this message:

MultiMedia Checker or mmcheck - Check Your openSUSE MultiMedia Setup in Just 16 Steps

Good Luck:

Thank You,

Wait a sec … I erred big-time and I pasted the wrong motherboard link. Sorry!! Mine is this one:

ASUSTeK Computer Inc. - Motherboards- ASUS P8P67 DELUXE

Asus A7N8X Deluxe Motherboard

Wait a sec … I erred big-time and I pasted the wrong motherboard link. Sorry!! Mine is this one:

ASUSTeK Computer Inc. - Motherboards- ASUS P8P67 DELUXE

Asus A7N8X Deluxe Motherboard
Well, someone seems confused. You have two links this time. The first is the Asus P8P67, a very good board while the second is a Asus A7N8X, a much older board that can only use AGP video cards. AGP cards will be hard to find these days and would not include any of the recent video cards as AGP usable. I used to own that very motherboard some eight years ago, but it would not be up to the tasks these days I fear.

Thank You,

Aarrgghh … no more linking, I do in fact have the A7N8X. Apparently every time I copied a link from Asus.com, it somehow gave me a different one. I’m not that dumb … honest!

So, I am S.O.L. with this old motherboard?

ekoblentz Aarrgghh … no more linking, I do in fact have the A7N8X. Apparently every time I copied a link from Asus.com, it somehow gave me a different one. I’m not that dumb … honest!

So, I am S.O.L. with this old motherboard?
No, I did a search and found some options. I most likely would select a nVIDIA 6200 from what I found and they are not expensive, but they may be used. I really did not look through it that well. Here is the link:

Google Shopping - Google Search

I would say that in the future, you got to be thinking about a new system before I would spend much money on the old. Of course, if it is working with Linux, you can continue doing what you have been doing I would think.

Thank You,

Cool, it’s very kind of you to do the research. At least I’ll save some money at the computer store. :slight_smile:

Did some homework just now (i.e. more Googling) and now I’m wondering why I bought a PCI card last time (several years ago) if AGP is better. Had I done my research back then, I might not be in this position now. Oh well.

Thanks again.

On 06/04/2011 05:06 AM, ekoblentz wrote:
>
> So, I am S.O.L. with this old motherboard?

look around for an old card…there must be millions on their way to
land fills…

my machine before this little power sipping one, had a ancient nVidia
GeForce FX 5500 which worked GREAT, fast smooth 3D, good movies, etc etc
etc…(with the proprietary nVidia driver)…

i see several on eBay this moment <http://tinyurl.com/3cqe959> for less
than $50…just make sure to get the one which fits your motherboard…

owwwww, NOW i see my friend from Austin has already fixed you
up…well, i’ll send since it is typed, and maybe you wanna save a Ben
Franklin! (you can use it for a tank of gas:)


dd CAVEAT: http://is.gd/bpoMD
[NNTP via openSUSE 11.4 [2.6.37.6-0.5] + KDE 4.6.0 + Thunderbird 3.1.10]
Dual booting with Sluggish Loser7 on Acer Aspire One D255

Today I went to Microcenter and bought the (PNY branded) GeForce 6200. I used the Nvidia one-click installation and it worked fine. Sure enough, when I rebooted and put in a DVD, the quality was much better than before.

One glitch: I use my 22-inch LCD in vertical / portrait mode, but when I opened the Suse ‘monitors’ menu, I can’t select any screen orientation other than ‘normal’ … the drop-down menu for selecting right/left no longer works, and I can’t find any similar option in the Nvidia application. What should I do? It’s important to me to have the monitor rotated.

A couple of approaches spring to mind here, although YMMV.

  1. I think xrandr may work for you here. Try playing with the commands first, then they can be added to a script as X starts (if they work for you).

This will give you the name of your display connection (DFP-0, VGA-0 etc)

xrandr

If your display is VGA-0 for example, you could rotate left with

xrandr --output VGA-0 --rotate left

Type

xrandr -h

for other options.

  1. It should also be possible to create a minmal /etc/X11/xorg.conf to do the same
Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    Option        "RandRRotation" "true"
    Option        "Rotate" "left"
EndSection

This Ubuntu post may be useful to you.

Good luck. :slight_smile:

Ack! I tried editing xorg.cong as described in the Ubuntu page linked above. Rebooted, but now it only goes into a command-line interface. It no longer opens Gnome. Help!!! I am in way over my head. :frowning: (Booted with the Live CD to send this message.)

PS - if any of you are feeling really helpful tonight then perhaps someone could help me via telephone?

Holy cow, I actually fixed something. It occurred to me that the xorg.conf file didn’t exist at all before I created it with the code suggested on the Ubuntu page … and Gnome booted fine before that … so if I could just remove the file, then it’d be back to square one, but at least I could use the computer, right?

Googled (via Live CD) for the Unix file deletion command. Found out that it’s “rm” not “del” like I expected from DOS days. This time it said I didn’t have permission. Okay, but I learned by osmosis that Sudo gives me that permission … so … changed directories and then sudo rm xorg.conf … yowsa it actually worked. Rebooted and back to my lovely though still normal-rotation GUI.

Now that I know how to delete a bum xorg.conf file, I tried again using the code quoted above. Computer booted normally, but the file didn’t have any impact on the screen rotation. It’s still in normal landscape mode and I still don’t have any choices other than ‘normal’ in the monitor menu.

Sigh …

Well done for getting out of that hole. Not sure what you did to get that xorg.conf file. Was it generated via the ‘nvidia-settings’ utility as the post described? One has to be very careful when editing system config files. It pays to become familiar with the CLI commands, including copying files for backup.

  1. Which desktop environment are you using? With KDE it is possible to rotate the display via System Settings>>Display and Monitor, however I don’t know how well this will work with the proprietary nvidia driver. There will be a similar display configuration utility with Gnome. Does that work for you?

  2. Did you try the xrandr commands that I gave you?

On 06/05/2011 05:06 AM, ekoblentz wrote:
>
> Ack! I tried editing xorg.cong as described in the Ubuntu page linked
> above.

it is not always safe to follow just any linux instructions you find out
on the web…

for one thing, *buntu and openSUSE are very different in some specific
areas…and, very alike in others–meaning some of the thing you learn
about *buntu work great on your openSUSE, other stuff makes a mess…

same goes for finding a problem solver for Red Hat, Mandrivia, etc etc etc…

knowing which is good and which is not is gonna take a while–suggest
you question here for your openSUSE problems…

and, if no one is around your first google should include words and
directions to seek openSUSE solutions only, like this string will only
search within the domain named:

site:opensuse.org

want only from the forums? then use site:forums.opensuse.org

ps: i’ve been using linux exclusively for about ten years and can NOT
always spot what in Ubuntu works or kills openSUSE, so don’t be
surprised to find i seldom look to other forums, for specific answers…

on the other hand: experimentation is often a learning experience, and
therefore encouraged–just plan a way back to smiles!


dd CAVEAT: http://is.gd/bpoMD
via NNTP openSUSE 11.4 [2.6.37.6-0.5] + KDE 4.6.0 + Thunderbird 3.1.10
on Acer Aspire One D255, 1.66 GHz Atom, 1 GB RAM, Intel Pineview graphics

  • When your gecko is broken you have a reptile dysfunction! *

Thanks.

No, that didn’t work. When I tried using the utility it just froze up and I had to force-quit it. Instead I just opened Gedit and created the file. But first I looked in the etc/X11/ directory and made sure I was viewing hidden files too. That way I wouldn’t accidentally overwrite the file if I already existed … which it didn’t.

Other than one semester of heavy Solaris use back in college (mid-1990s), my only CLI experience is DOS (assuming we’re not counting my childhood Apple IIe.) :slight_smile:

Gnome.

The same option exists here in Gnome. My problem is that it’s not working. But it worked with my crappy old ATI card.

Yes. When I typed xrandr is says “Failed to get size of gamma for output default” but it does say “Screen 0” which makes sense because I only have one monitor. When I typed the full line that you suggested, it says, “warning: output VGA-0 not found; ignoring”. Maybe I’m misunderstanding the “Screen 0” part?

Might be worth posting output of

xrandr

so we can see the display naming.

  1. Try creating a minimal /etc/X11/xorg.conf again
Section "Device"
    Identifier     "Videocard0"
    Driver         "nvidia"
    Option        "RandRRotation" "true"
    Option        "Rotate"  "left"
EndSection

Then, start the X-server, and if you get a working display, issue the xrandr command (as regular user with left, normal, or right as required):

xrandr -o left

Does that work?

  1. Maybe ‘nvidia-settings’ can work for you. Any options to rotate display?

It gives me this:

xrandr: Failed to get size of gamma for output default
Screen 0: minimum 320 x 240, current 1680 x 1050, maximum 1680 x 1050
default connected 1680x1050+0+0 0mm x 0mm
   1680x1050      50.0* 
   1400x1050      51.0  
   1280x1024      52.0     53.0  
   1280x960       54.0  
   1152x864       55.0  
   1024x768       56.0     57.0     58.0  
   896x672        59.0  
   832x624        60.0  
   800x600        61.0     62.0     63.0     64.0     65.0     66.0  
   640x512        67.0     68.0  
   640x480        69.0     70.0     71.0     72.0     73.0  
   576x432        74.0  
   512x384        75.0     76.0     77.0  
   416x312        78.0  
   400x300        79.0     80.0     81.0     82.0  
   320x240        83.0     84.0     85.0  

This may sound idiotic, but now when I try saving the new xorg.conf file, it says I lack permission to do so. I don’t remember what I did different last night to create it in the first place! Any suggestions?

About to log off my brain (aka going to sleep now) so I’ll check back into this thread tomorrow night.